New MōVI Firmware

Discussion in 'Announcements' started by Denise Fitzgerald, Jul 15, 2014.

  1. Thom Heald

    Thom Heald New Member

    Joined:
    Nov 9, 2013
    Messages:
    4
    Likes Received:
    1
    Hi all,

    I have updated to the new firmware without any major issues, and all seems to be working. The only thing is that the saved settings will not load.

    I go to System > Load Settings and select the .cfg file that I saved in Freefly > Parameters on my Nexus 7 tablet before updating the firmware, then this message appears:

    'File verification failed. Check all settings!'

    Bit frustrating as the Movi controller settings are all reset and they won't talk to each other now. Any ideas?
     
  2. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,383
    Likes Received:
    1,164
    Thom:

    Sounds like the .cfg is mangled. Unfortunately, it's a binary file (rather than plain text), so you cannot rebuild it manually. However, with the new firmware you can at least do the Autotune to reset the Stiffness settings.

    Did you, by chance, make any notes of settings that you changed? I suspect it's going to be a case of starting over.

    You might want to post the actual .cfg file (you don't need to change the file name), as I suspect Freefly developers may want to look at the .cfg file and see what's wrong.

    Andy.
     
  3. Tristan Twisselman

    Tristan Twisselman Active Member

    Joined:
    Jun 30, 2012
    Messages:
    416
    Likes Received:
    25
    I must say my FreeFly customer service has always been exceptional to the point even Tabb has talked to me personally and gone the extra mile to help. I think that is amazing and very rare these days so thumbs up FreeFly Team. Also I spoke with FreeFly support yesterday and today and they are going to send me the jumper cable for my new Movi coming so that if for some reason the update goes wrong I am not waiting for a cable.
     
  4. Thom Heald

    Thom Heald New Member

    Joined:
    Nov 9, 2013
    Messages:
    4
    Likes Received:
    1

    Thanks Andy, we didn't make a note of the settings but should be able to find the right ones again.

    I've attached the .cfg file for Freefly to take a look at.
     

    Attached Files:

  5. Jeff Modjeska

    Jeff Modjeska New Member

    Joined:
    Jun 28, 2014
    Messages:
    5
    Likes Received:
    0
    I downloaded the new firmware to my Android Nexus 7, The firmware download from Freefly works fine. The problem occurs when I try and open the file to extract it I'm getting an error that says can't open the file. This happens when I am connected to my Movi M5 and when I am not connected to the M5.

    Any help would be greatly appreciated!
    Jeff
     
  6. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    Jeff the bin file doesn't need to be 'extracted'. Any chance you can do a screen shot showing the error? Maybe the bin file didn't get onto the Nexus as a file?
     
  7. Tristan Twisselman

    Tristan Twisselman Active Member

    Joined:
    Jun 30, 2012
    Messages:
    416
    Likes Received:
    25
    movi came today, update successful but stressful watching it crawl across the screen lol
     
  8. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,383
    Likes Received:
    1,164
    I think you should be using the .apk file for the Android, Jeff.
    There is a direct download link on freeflysystems.com, then you need to find the download folder and tap on the .apk file you see there. The file is called Freefly_Configurator_Android_1.552.apk -- and after you've tapped on it, it should install automatically.

    Andy.
     
  9. Tuukka Ylonen

    Tuukka Ylonen Member

    Joined:
    Feb 19, 2013
    Messages:
    212
    Likes Received:
    7
    People here are talking about 75 value for autotuning M5. It says 70 on the upgrade manual. Which one is correct?

    And what is the recommended tuning setup for a Movi on a multirotor? I have done the autotune my multirotor and M5 suspended between two chairs and the multirotor hovering in the air.

    Both methods produced inferior results to previous manual tuning. I was using the value 70.
     
  10. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,383
    Likes Received:
    1,164
    I believe the correct numbers are 70 for M5 and 50 for the M10, Tuukka.

    Do you have the M5 in the support cradle, suspended, or hand held?

    It would also be helpful to know what settings you were using manually and what you are getting with Autotune.

    Andy.
     
  11. Ben Ruffell

    Ben Ruffell Active Member

    Joined:
    Jan 15, 2014
    Messages:
    229
    Likes Received:
    33
    For anyone following.

    The Jumper Cable was not set to arrive in time for the shoot….

    So, we made our own, (after emailing extensively with Freefly Support) and it worked.

    Movi M10 is alive again.

    Hope that a serious audit is undertaken by Freefly and the procedure is made a lot more robust for the future.
     
    Matthew Macomber likes this.
  12. Tuukka Ylonen

    Tuukka Ylonen Member

    Joined:
    Feb 19, 2013
    Messages:
    212
    Likes Received:
    7

    Hi Andy

    I auto tuned the gimbal with transmitter on and in remote mode and the copter suspended between two chairs. That has worked nicely before.

    The image stability is not quite as good as before. Please see the attached video. Maybe I should try a heavier lens? Or maybe red (more flexible) O-rings? Or is 50mm just too long a lens to achieve perfect stability? That being said I think I got better footage with 50mm on the old firmware.

    My settings are below. Camera is well balanced. The motors vary between 1 and 3% when the gimbal is not operated.

    Opinions?

     

    Attached Files:

  13. Brad Meier

    Brad Meier Active Member
    Staff Member

    Joined:
    Aug 14, 2012
    Messages:
    749
    Likes Received:
    66
    What were your settings before? Auto tune isn't meant to replace manual tuning but more to help those who don't know how to tune or had never tuned before. I suspect your settings before auto tuning were higher and closer to the threshold of oscillation, thus giving a tighter response and more stable footage.
     
  14. Dave Ketelhut

    Dave Ketelhut Member

    Joined:
    Jan 17, 2014
    Messages:
    35
    Likes Received:
    1

    Hey Ben,

    What are the instructions on the jumper cable?
     
  15. Ben Ruffell

    Ben Ruffell Active Member

    Joined:
    Jan 15, 2014
    Messages:
    229
    Likes Received:
    33
    I would talk directly with Freefly. They sent me one, but it only arrived today… after the shoot. So, we made our own. It was simple, but I still had my electrical engineer make it, but best to get instructions from them.
    It's very frustrating. I hope you fix it soon.
     
  16. Wolfgang Armin

    Wolfgang Armin Active Member

    Joined:
    Sep 20, 2012
    Messages:
    291
    Likes Received:
    25
    Finally I just upgraded my firmware. I usually try to wait as long as possible.

    BUT: I can´t connect to the MoVI with windows.
    I´ve done the update with my macbook pro using Windows. I saved my configuration as described in the manual. Everything went fine and I de-powered and re-powered the gimbal. But I can´t reconnect anymore to the MoVI. I rebooted the computer and the MoVI, but nothing changed.
    The interesting thing is: I can connect using the same notebook, booting it with MAC OS, and I can also connect with my android tablet.
    I would love to load my saved settings though, otherwise I wouldn´t even have used the Windows version at all. Any idea anybody what could be the reason?
     
  17. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,383
    Likes Received:
    1,164
    Wolfgang: Can you move the settings file over from the Windows environment into the Mac OS environment and use it there? I believe the file format is the same -- and it's worth a try.

    It seems odd that you can connected with Mac OS but not Windows...but, I'm a known Mac bigot and recovering Windows "end loser." :)

    Andy.
     
  18. Steve Maller

    Steve Maller UAV Grief Counselor

    Joined:
    Oct 30, 2012
    Messages:
    3,981
    Likes Received:
    807
    Have you updated to the latest Mac and Windows configurators? The version numbers are a little confusing, but once you update the MōVI, I believe the older utility software can no longer talk to it.

    http://www.freeflysystems.com/products/software/FreeflyConfigurators-071414.zip
     
  19. Wolfgang Armin

    Wolfgang Armin Active Member

    Joined:
    Sep 20, 2012
    Messages:
    291
    Likes Received:
    25
    Thanks you two for the input.
    Steve, yes I did. Both of them are the ones from the downloaded zipfile for the upgrade.
    Andy, that worked - hooray to the bigot ;-).
    Cheers,
    Wolfgang
     
  20. Charles Bergquist

    Joined:
    Aug 15, 2013
    Messages:
    89
    Likes Received:
    28
    Waited it out and updated tonight to 3.08. Everything said it went fine, update completed from Config. but on reboot of M10 I'm only getting one light and full limp on the MoVI. About to leave tomorrow afternoon and aerials on Friday, anyone have any ideas / tricks with this situation as it seems to be happening a lot. Email into support, but anything I could do tonight would be pretty helpful.

    MoVI M10 / Mac OSX / No Apps Running / Solid BT connection / Said Successful Install / One Light Full Limp

    Thanks all.
     

Share This Page