No Telemetry for MoVI Controller...

Discussion in 'MōVI Controller' started by Alec Caton, May 25, 2016.

  1. Alec Caton

    Alec Caton New Member

    Joined:
    May 23, 2016
    Messages:
    12
    Likes Received:
    0
    Hi guys,

    Interesting couple of days. So I recently updated our MoVI's to the new Akira firmware. Having had a couple of issues when Airborne (I understand it's still in beta testing) I decided to move back to Firmware V4.02.

    MoVI up/downdated fine, however the MoVI controller will no longer actuate the MoVI. I say actuate as binding doesn't seem to be a problem. Having reverted back to V4.02, I'm using the older MoVI app, I've been through to the radio configurator and switched to the MoVI Controller, wrote this process, however I'm now getting no telemetry readings through to the controller or any stick input or control. Interestingly, I can reboot the MoVI from the MoVI controller, but all the configuration settings for Pan/Tilt/Roll/ on the controller are reading '-1'. This also includes the Gyro Filter/Output Filter/Tilt Hold/Roll Hold/Pan Hold etc, all reading '-1' in the MoVI Controller configuration. Yet in the app, they are all present and correct as I've set them....

    Am I missing something?

    I'm running V2.0.5 on the controller and I've noticed the comms is reading '0' and I'm getting not telemetry readings in the MoVI Monitor Menu of the Controller...

    My guess is that reverting back the Firmware to V4.02 has caused issues. I'm able to bind, pair and control my old Specktrum controller to the MoVI without issues.

    Anyone else know of a fix or had similar issues...?

    ALSO!

    One little note...My previous members login isn't working (alec_caton) it's apparently still here and present (I can see and read my previous posts....but I'm locked out of it and it won't auto send a password reset to my email.

    Nightmare! Cheers guys!
     
  2. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,364
    Likes Received:
    1,162
    Alec:
    I'll investigate the state of your alec_caton account.

    After the upgrade/downgrade, did you restore the MōVI configuration file as it was from a previous save?

    Andy

    Forensic Software & sUAV / Drone Analyst : Photographer : Videographer : Pilot (Portland, Oregon, USA): Trees=2, Ground=1, Props=11. :(
    The Ground Is The Limit™
    ---------- Forensic Drone Analyst : Forensic sUAV Analyst : Forensic Unmanned Aircraft Analyst : Forensic Drone Expert
     
  3. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,364
    Likes Received:
    1,162
    Alec: Check for a PM from me. I reset the alec_caton account -- the PM states what it is.

    Andy

    Forensic Software & sUAV / Drone Analyst : Photographer : Videographer : Pilot (Portland, Oregon, USA): Trees=2, Ground=1, Props=11. :(
    The Ground Is The Limit™
    ---------- Forensic Drone Analyst : Forensic sUAV Analyst : Forensic Unmanned Aircraft Analyst : Forensic Drone Expert
     
  4. Jeff Scholl

    Jeff Scholl Distributor

    Joined:
    Jun 29, 2012
    Messages:
    240
    Likes Received:
    50
    The last time I ran into that problem I had DSMX for the Radio type instead of MoVI Controller. DSMX would still give me control of the gimbal but no telemetry or tuning functionality.

    Cheers,
    Jeff
     
  5. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    Alec

    Ignore that Johnson-Laird guy. Sent you a direct email with a new password.
     
  6. Alec Caton

    Alec Caton New Member

    Joined:
    May 23, 2016
    Messages:
    12
    Likes Received:
    0
    Hi guys,

    Ok, so I'm back (after 6 months!) basically we reverted everything back on the Firmware and stuck with Spektrum operation - I was getting the impression Akira wasn't quite ready and I couldn't risk the faults with a Summer of productions to get through. Anyway...I'm back! But unfortunately still having the same problem...If you read my previous post you'll see the issues, however the following has changed. The MoVI controller is now running V2.2.2 and both our MoVI M10 and M5 are running Akira V5.0.2. My assumption was that updates would help however I'm still struggling with our M5.

    I'm still getting the same readings on the MoVI controller for the M5 (I can reboot the MoVI from the MoVI controller, but all the configuration settings for Pan/Tilt/Roll/ on the controller are reading '-1'. This also includes the Gyro Filter/Output Filter/Tilt Hold/Roll Hold/Pan Hold etc, all reading '-1' in the MoVI Controller configuration. Yet in the app, they are all present and correct as I've set them....)

    The interesting thing is, the M10 connects and operates fine, with all telemetry readings as expected. Then something interesting happened. I powered on the M5 and after about 5 minutes it would actuate and replicate the joystick inputs being applied to the M10 (so they were operating simultaneously). So I powered down the M10 and the M5 continued to operate from the controller. I wrote these settings in the Radio Configuration and still operation was functional however all the configuration settings we not correct. So I powered down the controller and M5, restarted and was back to square one. Both bound together but the controller unable to actuate the MoVI M5 and all Config Settings reading -1.

    So...I switched the RX over on the MoVI's and still there was the same problem. It suggests to me that there's some issue with the MoVI M5. If there's any ideas it would be much appreciated!
     
  7. Alec Caton

    Alec Caton New Member

    Joined:
    May 23, 2016
    Messages:
    12
    Likes Received:
    0
    Just thought I'd post a quick update on this, just in case anyone else has similar issues, I found that in the terminal read out of the M5, the unit was stuck in a cycle of 'Key Request' and couldn't actuate. So I did I full reset through the default configuration and that appears to have solved everything for the moment...
     
  8. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,364
    Likes Received:
    1,162
    Good find, Alec. Any clue as to what might have caused that "Key Request" lockup?

    Andy

    Forensic Software & sUAV / Drone Analyst : Photographer : Videographer : Pilot (Portland, Oregon, USA): Trees=2, Ground=1, Props=11. :(
    The Ground Is The Limit™
    ---------- Forensic Drone Analyst : Forensic sUAV Analyst : Forensic Unmanned Aircraft Analyt S:I ZEo=r1ensFiocr DeRNoSnIEC ESxopfErttW[A/RCeO L&O Rs]
    UAV / Drone Analyst : Photographer : Videographer : Pilot (PoRtlaNd, Oregon, USA): Trees=2, GroUnd=1, ProPs=1!. :(
    The Ground Is The Limit™
    ---------- Forensic Drone Analyst : Forensic sUAV Analyst : Forensic Unmanned Aircraft Analyst : Forensic Drone ExpErt
     
  9. Alec Caton

    Alec Caton New Member

    Joined:
    May 23, 2016
    Messages:
    12
    Likes Received:
    0
    No clues as of yet. The MoVI M5 was working on Akira v5.0.2 when connected with the previous Spektrum set-up. I'm assuming it must have something user error based, but the restoring to default configuration resolved this.

    The only issue now is using the MoVI controller with the MoVI on a Multirotor...I'm getting some erratic behaviour which I'm assuming could be loss of signal.
     
  10. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,364
    Likes Received:
    1,162
    Are you seeing "spasms" when the gimbal control unit and antenna are occluded by the carbon fiber?

    Andy

    Forensic Software & sUAV / Drone Analyst : Photographer : Videographer : Pilot (Portland, Oregon, USA): Trees=2, Ground=1, Props=11. :(
    The Ground Is The Limit™
    ---------- Forensic Drone Analyst : Forensic sUAV Analyst : Forensic Unmanned Aircraft Analyst : Forensic Drone Expert
     
  11. Alec Caton

    Alec Caton New Member

    Joined:
    May 23, 2016
    Messages:
    12
    Likes Received:
    0
  12. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,364
    Likes Received:
    1,162
    Alec: I'm not certain I'd say "not up to it," but I suspect that when airborne it's a more radio-frequency noisy environment -- and that is causing issues. Certainly the 2.4Ghz RF amps make a difference based on what Derek Cooper et al. have reported (which tends to confirm the noisy RF environment theory).

    Andy

    Forensic Software & sUAV / Drone Analyst : Photographer : Videographer : Pilot (Portland, Oregon, USA): Trees=2, Ground=1, Props=11. :(
    The Ground Is The Limit™
    ---------- Forensic Drone Analyst : Forensic sUAV Analyst : Forensic Unmanned Aircraft Analyst : Forensic Drone Expert
     

Share This Page