MK software update

Discussion in 'Electronics' started by Joe Azzarelli, May 3, 2013.

  1. Joe Azzarelli

    Joe Azzarelli Active Member

    Joined:
    Jul 13, 2012
    Messages:
    210
    Likes Received:
    26
    Has anyone installed the latest FC and Nav updates from MK?

    If so, any issues?

    Joe
     
  2. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    Joe I am on .90d/.30b. No problems and is flying fine. The latest is .90g/.30g here's the deltas.

    0.90g

    • ACC-Z data fusion for much more accurate and direct altitude hold (Update from FC2.1 to FC2.2 (ACC-board) required)
    • During calibration the tilt-angle of the MK must be within 20° - otherwise the Mk will report "Error calibration"
    • Hold I-Parts of the attitude control to zero when the MK is still on the ground (until 1,5m) for easier takeoff
    • ACC-Altitude sensor data fusion implemented to the altitude controller (HW-Update from FC2.1 to 2.2 needed)
    • Parameter Reset, if the HW-Version changes (FC2.1 to 2.2)
    • disable Yawing when Gas-Stick is to Zero
     
  3. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,383
    Likes Received:
    1,164
    I'm also flying FC HW:2.1 SW:0.90d + NC HW:2.0 SW:0.30a. (Didn't realize there was 0.30b....my mistake.)

    The only oddity I've noticed was on three occasions yesterday, I couldn't throttle up the motors. Once Frau Graupner said "Error" after motor start, otherwise the motors would start but not throttle up on command. There is no trace in the GPX files as to what the problem might be -- I surmise it was a low GPS satellite count, but I didn't see that reported in the Smart OSD, so right now it's a bit of a mystery.

    It happened with flights 4, 5, and 6 of a nine flight session. In all cases I had connected up the flight battery and had left the C8 powered up, but not with motors running (while I sipped some coffee). The Kp Index was at 4 yesterday so that might be related.

    Alternatively, the C8 was upset that it was powered up and ready to go and there I was faffing around drinking coffee. ;)

    The workaround in all three cases was unplug the flight LiPo, and reconnect it. In one the middle case (flight 5), the copter also started to signal the J-code (no Tx signal) and the MC-32 was beeping (No Tx). Again, the disconnect/reconnect of the LiPo seemed to correct it.

    No other anomalous behavior (other than the way the pilot was flying). :D

    Andy.
     
  4. Joe Azzarelli

    Joe Azzarelli Active Member

    Joined:
    Jul 13, 2012
    Messages:
    210
    Likes Received:
    26
    I noticed on 3 occasions yesterday I could not get my copter off the ground because PEOPLE WONT LEAVE ME ALONE! :)

    But seriously... I was at a new location by myself and folks just felt compelled to ask me questions while I am flying in gusty wind conditions. Things like
    "aren't you worried it will fall into the lake??" (always) ​
    "is it safe?" (not for you if you don't move away from me)​

    Andy a tip for you: Every time my C8 gets upset with me I just land really hard to remind it who's the boss. Take that!

    On the serious side - I did not see that Quadrocopter is selling the upgrade ACC board - where can I source?

    Joe
     
  5. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,383
    Likes Received:
    1,164
    I'm still wondering whether to do a little tri-fold handout and have a "Please take one" box that I set up so the passers by can get their questions answered.

    Yeah....a good hard ground intersection (aka "landing") shows it who's boss without a doubt. Mind you, the gimbal gets bent out of shape (literally and metaphorically).

    I don't think QC has the the ACC upgrade in yet -- but I believe altigator.com has them.

    Andy.
     
  6. Duane Bradley

    Duane Bradley Active Member

    Joined:
    Dec 6, 2012
    Messages:
    212
    Likes Received:
    26
    Same problem with mine lately. A couple of time while flying in the boonies a few weeks ago and again once last week. Very intermittent and no rhyme or reason (that I could) find to it. Same solution - unplug and replug.
     

Share This Page