Movi Pro Horizon Issues

Discussion in 'MōVI Pro' started by Chris Bacik, Oct 25, 2018.

  1. Chris Bacik

    Chris Bacik New Member

    Joined:
    Aug 27, 2018
    Messages:
    7
    Likes Received:
    0
    We are having horrible horizon hold with our Movi Pro and I am wondering if anyone has seen it this bad? Freefly's support seems to be non-existent so I am not sure what to do at this point... Here is a sample of what I am talking about. Prior to looking down (which I don't show) the horizon perfect/level. 15+ satellites present for this video, although even if I had 0, I don't understand how it can be this bad...

     
  2. Graham Futerfas

    Graham Futerfas Active Member

    Joined:
    Oct 19, 2015
    Messages:
    983
    Likes Received:
    203
  3. Angus Benson-Blair

    Angus Benson-Blair Active Member

    Joined:
    Jan 23, 2013
    Messages:
    144
    Likes Received:
    25
    We are having exactly the same issues and we don't use GPS hold for the reasons mentioned all over the place and also we dont use the compass assist as this too has its issues. Some days the horizon works well and yesterday it was terrible with the roll moving approx 45degrees in a simple move forward.
     
  4. Chris Bacik

    Chris Bacik New Member

    Joined:
    Aug 27, 2018
    Messages:
    7
    Likes Received:
    0
    Angus, just out of curiosity, when did you purchase your Movi Pro?
     
  5. Angus Benson-Blair

    Angus Benson-Blair Active Member

    Joined:
    Jan 23, 2013
    Messages:
    144
    Likes Received:
    25
    It was one of the first batch
     
  6. Chris Bacik

    Chris Bacik New Member

    Joined:
    Aug 27, 2018
    Messages:
    7
    Likes Received:
    0
    That's scares me. I just sent back one of my Movi Pros thinking the drift may be hardware related (same roll problem happens on both of my Movi Pros). I am starting to believe more and more it is a firmware issue though.
     
  7. Angus Benson-Blair

    Angus Benson-Blair Active Member

    Joined:
    Jan 23, 2013
    Messages:
    144
    Likes Received:
    25
    We have the problem on two systems. I think it is firmware related but a new firmware is due out very soon that concentrates on roll things in terms of features and fixes. Fingers crossed!
     

Share This Page