Movi M10 and Canon C500

Discussion in 'MōVI M10' started by Lloyd Aygun, Jan 10, 2017.

  1. Lloyd Aygun

    Lloyd Aygun New Member

    Joined:
    Jan 9, 2017
    Messages:
    3
    Likes Received:
    0
    Hi All

    I've done a search but couldn't really find a definitive guide so hopefully any answers here will help others in the future too!

    I've just purchased an M10 (after the awesome price drop) and am trying to get it setup with the Canon C500, does anyone have or know of a good full proof guide to help with this camera? I've tried mounting it following other guides and it just doesn't seem to work as the C500 is so tall it bangs against the edges and there just seem like any room to balance?

    Also I bought longer rods (was given this advice) so that I could still use the top bar as this would supposedly make it easier to balance but again this totally failed as the rods really struggled to move up and down the side cage (seemed to fat despite being standard rods) and again the camera was just too tall.

    Does anyone have any advice as I'm really falling at the first hurdle!

    Thanks in advance
     
  2. alain baars

    alain baars Member

    Joined:
    Feb 5, 2014
    Messages:
    164
    Likes Received:
    5
    The C300 and the C300M2 have the same problem, I don't know what the size of the 500 is compaed to these tw, but the problem is known.
    It helps if you can get rid of the EVF, as possible with the C300. If you use heavy lenses you have to rig it backwards, which increase yor problem, lighter lenses make the camera move forward to balnce, which makes life easier for you.
     

Share This Page