CS8 HL Strange behavior: Magnet Error

Discussion in 'Cinestar 8' started by Artur Brosig, Oct 28, 2015.

  1. Dave King

    Dave King Well-Known Member

    Joined:
    Dec 24, 2012
    Messages:
    2,711
    Likes Received:
    311
    No 2.12 isn't in beta, 2.11 was in beta and never released as an official update.
     
  2. Artur Brosig

    Artur Brosig New Member

    Joined:
    Apr 21, 2015
    Messages:
    20
    Likes Received:
    0
    Nice,
    I'll update it now.
    Thanks
     
  3. Artur Brosig

    Artur Brosig New Member

    Joined:
    Apr 21, 2015
    Messages:
    20
    Likes Received:
    0
    I've tied the wires, both the LiPo and motors.
    I've also updated the firmware of both the FC and NC.
    The motors cables are a bit long, so a bunch of wires cross each other inside the frame. Perhaps i should tie together the motor wires in pairs (wires of the motor 1 and 2 together - the pairs that come together from the board - and so on..) ? It should help reduce the magnetic interference or it's only more work for low or none improvement?

    I did not have enough courage to make a test flight, and also there is a bit higher solar interference this days, so i'll wait it calm down.
    Some pictures of the cables:
    LiPo_lead.jpg mess.jpg motor_lead.jpg

    Thanks again
     
  4. Dave King

    Dave King Well-Known Member

    Joined:
    Dec 24, 2012
    Messages:
    2,711
    Likes Received:
    311
    Looks good. I flew yesterday with the KP index at 4 and had no issues.
     
  5. Jason Smoker

    Jason Smoker Active Member

    Joined:
    Oct 23, 2012
    Messages:
    847
    Likes Received:
    67
    Atur you might want to consider cutting and resoldering those motor wires. I did mine after i upgraded my motors its real pain in the ass but it help the reduce the magnetic interference. It took me about 4hrs :confused:. I havent seen any problems since.
     
  6. sven Hebbard

    sven Hebbard Member

    Joined:
    Oct 28, 2015
    Messages:
    34
    Likes Received:
    0
    Artur Did you have a chance to try your external compass and Navi v2.1?


    My 2.0 board is on the fritz, So i'm looking at bumping up to the newiest item, But with my nav board on the boom arm already, And the 2.0V nav boads out of stock. I'm wondering if the v2.1 is worth it with external? and where did you mount your compass?
     
  7. Artur Brosig

    Artur Brosig New Member

    Joined:
    Apr 21, 2015
    Messages:
    20
    Likes Received:
    0
    Hi Jason,
    I tried to make the motor cables as tight as i could, but i think that i don't have the courage to redo the soldering.. :D Maybe as last option.
    I still haven't eliminated all the problems. I did updated it, but some configurations have lost, so i'm going to review all of it before any flight test.

    Sven, my board is the v2.0. I have not bought it yet the external compass and, as i'm in Brazil and the importation process here takes so long, i think that i'll manage to solve the most part of my problems before the external compass arrives. And i have no idea where to mount the compass, but i think that even if you put it on the arm with the navi board, the result will be better than the on board compass.. Maybe someone can correct me if i'm wrong. :D
     
  8. Jason Smoker

    Jason Smoker Active Member

    Joined:
    Oct 23, 2012
    Messages:
    847
    Likes Received:
    67
    Artur you might find you have to get rid of the problems but the choice is up to you. One day of soldering bliss :eek:. Its always good to a screen shot of each page before you update or change anything and save it. Comes in handy when wipes it self

    Sven you don`t need the 2.1navi board to use the external compass, you can use it the navi 2.0 just requires some skilled soldering. That anti-noise capacitor is a real test without bridging the pins with solder.

    you can read about here
    http://wiki.mikrokopter.de/en/ExternalCompass
     

Share This Page