Your Radian gains?

Discussion in 'Radian' started by Brad Meier, Sep 19, 2012.

  1. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,366
    Likes Received:
    1,162
    Oh...him -- yeah, well, I'll let him respond. <evil grin>

    He's also the best guy to respond to the servo/play question too.

    Andy.
     
  2. Bo Tornvig

    Bo Tornvig Member

    Joined:
    Oct 14, 2012
    Messages:
    160
    Likes Received:
    14
    Ok - Thanks..
     
  3. Matt C

    Matt C New Member

    Joined:
    Oct 31, 2012
    Messages:
    15
    Likes Received:
    2
    I think my last post may have been deleted so I'll post again.
    We are having EXACTLY the same issues as brad with the juddering of the Cinestar 3 axis gimbal with Radians.
    We have also done all the tests such as flying with disconnected belts and flying with the radians turned off and the footage is buttery smooth.

    Our only conclusion is that it's the radians, belts and servo slop on a micro level that feed the noise back to the radian and it just can't handle it. We've tried gains from 50 right up to 220 and we get the same juddering issues, particularly on the roll axis.

    At low gains, the juddering eases, but the gimbal is slow to compensate. The opposite happens with high gains, but as I said, the juddering is always there.

    I feel that the radian software needs some sort of noise filter slider to elimenate this high frequency feedback into the system.

    We created some anti vibration mounts and the problem has eased somewhat, but it's still there.

    Can anyone help me with some ideas?

    Also, to the guys at Freefly, are you able to implement remote gain tuning so we can tune the gimbal inflight?

    Cheers

    Matt
     
    Forrest12 likes this.
  4. Sedric "Zellevision" Sari

    Joined:
    Sep 21, 2012
    Messages:
    87
    Likes Received:
    2
    Hi all. Have 3-axis aswell and did the fw yesterday to 1.03. Had perfect working setup, but now same problems with the roll as you guys! Roll has some strange jitter I never seen before. Possible to go back to 1.02. Had lower gain with the 1.02, gain75 and perfect horizont, now around 220 and NOT perfect, tryed them all, from 20 to 270....

    Aaaand I liked the control on mode as it was before, that the pilot/pwm was overruling the spektrum/cameraman.

    Tilt works as before, didnt need to change any values, just the channels :) The pan is still to be tested.
     
  5. Bo Tornvig

    Bo Tornvig Member

    Joined:
    Oct 14, 2012
    Messages:
    160
    Likes Received:
    14
    Hi, Here is at small test of the radians: roll 125 - tilt 90. It´s calm weather. 4-5 Miles per Hour. The Stabilization on the camera is off and there is - clearly no post stab.

    I´m running out of options.
    Could be great if some of the FreeFly guys could comment on this issue.



    Cheers
    Bo
     
  6. David Pearce

    David Pearce New Member

    Joined:
    Nov 30, 2012
    Messages:
    16
    Likes Received:
    0
    I need some help with servo directions in my 3 axis gimbal. I was able to reverse the servos in my DX7 to have the controls corrected for tilt and roll but can't seem to do it on the Pan. I still have left action when I push the right stick to the right...

    Any suggestions?
     
  7. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,366
    Likes Received:
    1,162
    @David:
    David, I'm not familiar with the DX7. But I did a Google search and found the manual.

    Can you first confirm on the DX7 itself that you're getting full travel in both directions on whichever servo you're using for the pan. Use the Servo Monitor screen (page 77 of the manual). Then check Travel Adjust (page 55).

    Can you also confirm that you have disconnected the potentiometers from all of the servos and replaced them with the resistors that came with the Radian sensors.

    Thanks
    Andy
     
  8. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,366
    Likes Received:
    1,162
    Hi Bo:
    The jitter in roll looks almost like incipient oscillation. One thing I found is that you really have to "sneak up on" the sweet spot with the servos. I started by making changes in 5% or 10% increments and discovered I would blast right by the sweet spot -- either I'd get oscillation or "dead" response....so I tried just changing the gains 1% at a time and finally found the sweet spot.

    If this doesn't help, could you post a screen shot of the Radian Diagnostic and Configuration window for the Roll sensor please?

    Also the sweet spot seems to change depending on the payload camera I'm flying.

    Thanks
    Andy
     
  9. David Pearce

    David Pearce New Member

    Joined:
    Nov 30, 2012
    Messages:
    16
    Likes Received:
    0
    Confirmed on both of those Andy.
     
  10. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,366
    Likes Received:
    1,162
    So the only issue is the control reversal on Pan, is that correct?
    I'd be curious to see if the control reversal was showing up on the Servo Monitor screen? If you remove the control reversal does the Servo Monitor reflect that?

    The next thing I'd try, presuming you have MK Electronics is to connect up MK Tool and look at the Channels window to see what the pan channel is showing -- does it reflect the control reversal or not?

    Hope that helps.
    Andy.
     
  11. Matt C

    Matt C New Member

    Joined:
    Oct 31, 2012
    Messages:
    15
    Likes Received:
    2
    Could someone from FF look at and respond to my post #203 above please?
    It looks like a few people are getting a lot of roll oscillation and it would be good to have some suggestions or answers to fix the issues..
     
  12. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,366
    Likes Received:
    1,162
    Let me ask Tabb and/or JohnC if they have a moment.

    Andy.
     
  13. Tommy - KnightDesignDev

    Joined:
    Sep 18, 2012
    Messages:
    38
    Likes Received:
    1
    There are a few questions I have, or items to note that i didn't see in my quick scan of the thread.
    We had a few issues with hardware vibrating loose, specific to the pulley on the Servos.
    • Tight Hardware
    • Proper servo to pulley skew - and belt tightness ( big to small in a FLAT PLANE )
    Servo Speeds will likely play into this equation more than it has been stated.

    Pan: 60-80
    Roll: 90-130
    Tilt: 150-220
     
  14. JY Air

    JY Air New Member

    Joined:
    Sep 20, 2012
    Messages:
    20
    Likes Received:
    0
    Struggling with the same problem.
    Still is not resolved. T ^ T
     
  15. Bo Tornvig

    Bo Tornvig Member

    Joined:
    Oct 14, 2012
    Messages:
    160
    Likes Received:
    14
    Hi there,

    Yesterday we had calm weather and I went out for a new test and followed Andy's method by increasing the gain level little by little.
    Camera stabilization is off. I ended up with Radian gain 95 on the roll - as the best result. But unfortunately still far from good.
    There is only a very little difference between the gain settings. The only difference I see - is the jitter only becomes more aggressive doing the increasing of the gain level. All the way up there is this unwanted mechanical "ground" jitter no matter what gain I put in.
    I´m still thinking that the mechanical play in the servo gearset plays a big part in the roll jitter.
    What do you guys think?

    Cheers
    Bo
     
  16. Tim Joy

    Tim Joy Active Member

    Joined:
    Aug 2, 2012
    Messages:
    405
    Likes Received:
    72
    I've mentioned it several times on this forum and sorry to repeat myself, but it might be worth it to install some felt under the servo pulley between the case, to help reduce the effects of gear backlash. As I see it, that is usually the issue when an axis is constantly "hunting". The only other suggestion would be to try a lower gear ratio, as the movements are very small at this level.

    I will be setting up my radians next week so maybe have some more useful 1st hand experience after that!
     
  17. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,366
    Likes Received:
    1,162
    @Bo:
    Apologies if this has already been asked and answered (I went back through this thread but couldn't see an answer), but what firmware are you running on the Radian servos?

    Also, is this only an "in flight" problem, or can you reproduce it on the ground if you suspend the Cinestar? What I was wondering was whether might be possible to see the Diagnostic window for the Radian roll sensor while this twitching is happening.

    Andy.
     
  18. Pavlos Antoniou

    Joined:
    Oct 6, 2012
    Messages:
    321
    Likes Received:
    18
    Are we sure that we dont need stiffer dampers but we need fewer dampeners???

    Have you ever tried this??

    On my old gimbal that it was 2.5kg i have tried to put 4 of the 6 dampers on its side and it was very good..! but on this gimbal i had not tried to put 6 so i cannot compare... what you think?
     
  19. Bo Tornvig

    Bo Tornvig Member

    Joined:
    Oct 14, 2012
    Messages:
    160
    Likes Received:
    14
    Hi Pavios,
    I´m flying in relative cold weather, so I have removed 2 out of 6 O-rings (the red ones). If I dont - Ill get rolling shutter effect.
    Best Bo
     
  20. Bo Tornvig

    Bo Tornvig Member

    Joined:
    Oct 14, 2012
    Messages:
    160
    Likes Received:
    14
    Radian2.png
    Thanks for your reply.
    I was running 1.02 firmware - but in the process of finding out what firmware I was running, I´d find out that there was a new one. So I upgraded straight away. And it´s great!!! prefect control of my tilt - I´m very pleased abut that new feature :)
    But as I understand it - the new firmware have no effect on the roll issue...? I don´t have the weather right now to see if there´s any improvement - snow storm.... :(
    Also you asked for a screenshot of my Radian settings.
    Cheers
    Bo
     

Share This Page