Wiring spectrum receiver to alexmos

Discussion in '3 Axis Gimbal' started by Devin Card, Feb 19, 2014.

  1. Devin Card

    Devin Card Member

    Joined:
    Mar 6, 2013
    Messages:
    118
    Likes Received:
    8
    Having problems finding info on how to wire spectrum receiver to alexmos 3 axis board in order to control my pitch and yaw of gimbal while in air.
    Anybody out there figured this out?

    Cheers,
    Devin
     
  2. Chris Newman

    Chris Newman Member

    Joined:
    Oct 9, 2012
    Messages:
    200
    Likes Received:
    14
    Yeah, what does your board look like? and what receiver?
     
  3. Steve Maller

    Steve Maller UAV Grief Counselor

    Joined:
    Oct 30, 2012
    Messages:
    3,979
    Likes Received:
    807
    Don’t know if it’s the same (it’s all PWM, right?), but I did that with my Graupner GR12 by just running servo cables from the receiver to the RC_ROLL and RC_PITCH connectors on the Alexmos board. Then in the GUI you can assign which connector controls which function with the RC Input Mapping function.
     
  4. Devin Card

    Devin Card Member

    Joined:
    Mar 6, 2013
    Messages:
    118
    Likes Received:
    8
    The board is the brand new 3 axis board, and im trying to use a spectrum dsmx receiver, also have an ar8000 available if needed.
    Can you guys post photos of wiring?
     
  5. Steve Maller

    Steve Maller UAV Grief Counselor

    Joined:
    Oct 30, 2012
    Messages:
    3,979
    Likes Received:
    807
    Does your Alexmos board have RC_ROLL and RC_PITCH connectors?
     
  6. Devin Card

    Devin Card Member

    Joined:
    Mar 6, 2013
    Messages:
    118
    Likes Received:
    8
    Yes it does steve. Tried multiple different combos and different things on board and GUI
     
  7. Chris Fox

    Chris Fox Active Member

    Joined:
    Apr 14, 2013
    Messages:
    463
    Likes Received:
    86
    G'Day Devin,

    Are the cables all orientated the right way around? I was delivered an Alexmos board a while back, that had all the signal wires plugged into the ground side of the servo plugs .... I was tearing my hair out until I had close look to find this was the problem, I swapped the wires to the correct side of the servo plug and then like magic it worked ....

    Just something to double check.

    Cheers
    Chris
     
    Devin Card likes this.
  8. Devin Card

    Devin Card Member

    Joined:
    Mar 6, 2013
    Messages:
    118
    Likes Received:
    8
    I'll check the wiring Chris thanks!

    What i am not clear on is attaching the spectrum dsmx receiver....in the past, on the radians you just plugged it in and it works with a servo cable....Ive read online that you must cut the red cable (power?) and then I am guessing you have to supply from somewhere else.....

    Anybody have a photo or link of their set up??

    Cheers,
    Devin
     
  9. Steve Maller

    Steve Maller UAV Grief Counselor

    Joined:
    Oct 30, 2012
    Messages:
    3,979
    Likes Received:
    807
    How are you powering the Spectrum receiver?
    On my Graupner (the 2nd receiver, mounted on the gimbal...not the main receiver, mounted above), I supply power from the Alexmos board using all three wires of a servo cable. But there is a jumper on my board that has to be shorted in order for the Alexmos to supply real 5VDC on the red wire. Once that’s done, it works fine. I think you have to be careful with your grounds, too. But I’m not an expert on that stuff.
     
    Devin Card likes this.
  10. Duane Bradley

    Duane Bradley Active Member

    Joined:
    Dec 6, 2012
    Messages:
    212
    Likes Received:
    26
    I just bumped into this problem as well. I have the High Power Elite AlexMos whcih does not give an option of powering a receiver from it since all the 5V supply points the MA are too low. I picked up a BEC at my Hobby shop and am splicing that into my power feed to the AlexMos.

    The setup I'm building will have one 4s, and the power split 3 ways; Full power going to the AlexMos, Full power going to my Iftron, and BEC going to my Spektrum Rx.
     
  11. Devin Card

    Devin Card Member

    Joined:
    Mar 6, 2013
    Messages:
    118
    Likes Received:
    8
    Hey Duane,
    Were you able to get this up and running like this?
     
  12. Duane Bradley

    Duane Bradley Active Member

    Joined:
    Dec 6, 2012
    Messages:
    212
    Likes Received:
    26
    For the most part yes. I decided to keep the Iftron separate as it may be the first thing replaced on the rig in the future. So I'll keep running the video downlink with its own tiny 1000mah 3s.
     
  13. Devin Card

    Devin Card Member

    Joined:
    Mar 6, 2013
    Messages:
    118
    Likes Received:
    8

    And were you able to power receiver and get rc working by using bec?
     
  14. Duane Bradley

    Duane Bradley Active Member

    Joined:
    Dec 6, 2012
    Messages:
    212
    Likes Received:
    26
    Yes
     
    Devin Card likes this.
  15. Devin Card

    Devin Card Member

    Joined:
    Mar 6, 2013
    Messages:
    118
    Likes Received:
    8
    Have gotten power to ar8000 and spectrum and spectrum satellite receiver but still can get and commands across.
    I selected PWM and rc-pitch in gui? Anything else to do?
     
  16. Chris Odom

    Chris Odom Member

    Joined:
    Jul 29, 2012
    Messages:
    41
    Likes Received:
    5
    Wondering if anyone has gotten this to work. I am pulling my hair out trying to get the spektrum ar8000 or the satellite to work. I can see that there is an impulse on each but on the 8000 the channel that is supposed to be controlling the input doesnt move, just a bar indicating signal. Then when I switch over to the satellite and choose the vir channels, I can see that there is some input on certain channels but for some reason they are very wonky, ie I am trying to set my user profiles to a 3 position switch and the closed I can get on one of the virtual channels is way below or all the way full equating it to a two position switch. Does anyone know where there is a tut on how to configure this or have suggestions?
     

Share This Page