Various Issues With Spektrum DX8 On M5

Discussion in 'MōVI M5' started by Veve Borimov, Nov 24, 2014.

  1. Veve Borimov

    Veve Borimov Member

    Joined:
    Nov 1, 2013
    Messages:
    70
    Likes Received:
    7
    Hi everyone,

    Ok so I need a little bit of help and don't want to overload the support team until I know no one here can help :D

    Issues with the remote (compared to a different remote paired with a different M5)

    1: On the DX8's LCD panel, it says Aero instead of MoVI. On our 2nd MoVI M5 it says MoVI.

    2: When I start the remote, it will start beeping (same noise as for low battery) with the following messages showing on the remote's LCD panel:
    Throttle High
    Flaps Landing Postion
    This does not happen with our 2nd MoVI M5.
    To stop that warning, I need to put the left joystick down and the remote/maj/kill switch on remote mode. This does not happen with the 2nd remote. We can start it with all switches/joysticks in any position we want.

    3: The DX8 doesn't seem to pair up with the M5. When we bind it again, the M5 recognises the remote but the tilt axis doesn't seem to work. And then after a while, the remote and MoVI unpair themselves from one another.
    If paired, sometimes the DX8 receiver on the MoVI will start flashing even though the remote communicates with the MoVI just fine.
    Our 2nd unit does not behave like that.

    We have done default settings, restore factory cal, reset controller and bnd controller. None have resolved our issues.

    The settings inside the app are exactly the same on both units.
    When we bind the remote from our 2nd M5 onto the one mentioned above having issues, it works fine. The LCD displaty shows MoVI instead of Aero, there are no warning beeps when turning the remote on with the joystick down etc.

    Is it a faulty remote? Is there a wait to reset the settings inside the remote? Tried to look but can't find such menus. Is there any way I can export the settings from my 2nd DX8 and load it onto the unit having issues? I see an SD card slot on the DX8, not sure what I can do with it.

    Thanks for your help!
     
  2. Jason Smoker

    Jason Smoker Active Member

    Joined:
    Oct 23, 2012
    Messages:
    847
    Likes Received:
    67
    Hey Vive,
    I am going to try and help you.
    1) On the DX8's LCD panel saying movi. This is easy to change when you turn on the dx8 hold down the scroll button there is a setting ''model name" change it to what ever you please

    2) This is normal if you have it in aero mode, You may want to consider a "Model copy" into a new model number this is in the same menu as above. Its simple enough to do

    3) Make sure when you turn on the dx8 and power up the m5 satellite that the light is lite on the spektrum satellite they is a little orange light. This is confirmed that is bind and ready. If this not the case take the satellite of the movi and rebind it.

    Once you have confirmed its bind you will need to config the dx8 to the movi using the movi app instructions on page 31

    http://d27w8s76bjlz9v.cloudfront.net/wp-content/uploads/2014/07/FFS_M5-Manual.pdf
     
    Veve Borimov likes this.
  3. Veve Borimov

    Veve Borimov Member

    Joined:
    Nov 1, 2013
    Messages:
    70
    Likes Received:
    7
    Hi Jason,

    Thank you SOO much for the in-depth response. I will give it a try and get back to you to let you know how it works out.

    Thanks for your time again!!
     
  4. Mark Langille

    Mark Langille Member

    Joined:
    Jun 2, 2014
    Messages:
    32
    Likes Received:
    1
    You can disable the various alarms and warnings on the DX8 as well for each model.
     

Share This Page