Tilt not working in stabalized mode

Discussion in 'Radian' started by Matt O'Brien, Apr 19, 2013.

  1. Matt O'Brien

    Matt O'Brien Member

    Joined:
    Mar 16, 2013
    Messages:
    58
    Likes Received:
    1
    Hi Guys,

    Im using the dx6i and my tilt works no problem in stabilized+slew but when I am just in stabilized mode the tilt is not responding on channel two even though on the input monitor I see it going up and down. I am sure it is a simple setting in the program any ideas?
     
  2. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,366
    Likes Received:
    1,162
    Hi Matt:
    In Stabilized Slew you will have control of tilt.
    In Stabilized Fixed, you do not. Roll will still be automatic. You can program up the fixed angle you want for tilt in the Radian software.

    Andy.
     
  3. Matt O'Brien

    Matt O'Brien Member

    Joined:
    Mar 16, 2013
    Messages:
    58
    Likes Received:
    1
    o0o okay got ya. So you have to always preset the stabilized fixed position before flight? Also I think in one of the modes I do not remember which if I push up on the throttle once it gets to 100 percent it goes to off mode, is that normal?
     
  4. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,366
    Likes Received:
    1,162
    Hi Matt:

    Well, you don't have to preset the Stabilized Fixed position before each flight -- you program up the Radian tilt sensor for the setting that you want and it maintains that until you program a different setting.

    Errr.....not quite sure what you're saying here....the throttle and the Radians's Mode setting are normally completely independent.
    That said, with a 2-axis gimbal, I suppose you could program the tilt and roll Mode channel to be channel 1 -- then the throttle would effectively control the mode, but that would lead to a very odd configuration -- you'd be in Stabilized Fixed if you hovered, but Stabilized Slew if you were climbing. Not quite sure that's the effect you would want.

    What effect are you trying to get -- I may be completely misunderstanding what your heading for....

    Andy.
     
  5. Matt O'Brien

    Matt O'Brien Member

    Joined:
    Mar 16, 2013
    Messages:
    58
    Likes Received:
    1
    No I am not asking for an effect I am just saying that when I am in stabilized fixed mode and i push my left stick (throttle) all the way up it turns the radians off and all lights start blinking as if I turned the gimbal off from the controller. Once i pull the stick back down to what would be zero throttle it turns back on. I was just wondering if this was normal in this setting?
     
  6. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,366
    Likes Received:
    1,162
    That's not normal at all.
    Can you connect up the Radian software to each of the Radians in turn and take screen shots of the Diagnostic and Configuration Windows and upload those files as part of a reply to this thread, please?

    It sounds like one of them is programmed to have the Mode control on Channel 1 (the throttle), but we can tell that from the screen shots.

    There should be no interaction between throttle and the Radian settings.

    Andy.
     
  7. Matt O'Brien

    Matt O'Brien Member

    Joined:
    Mar 16, 2013
    Messages:
    58
    Likes Received:
    1
    OK so here's the deal in stabilized + slew everything is fine there is no reaction when I move the throttle stick. Once I got to fixed stabilized and the throttle is down its fine but then when i move the throttle up the mode goes back to red like you see below in the 3rd pick.

    [​IMG] Stabilized + Slew.jpg Stabilized + Fixed throttle down.jpg Stabilized + Fixed throttle up.jpg
     
  8. Matt O'Brien

    Matt O'Brien Member

    Joined:
    Mar 16, 2013
    Messages:
    58
    Likes Received:
    1
    Another strange thing that happens is I choose spektrum because that it what I use and when I hit connect it automatically goes to sbus why?
     
  9. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    Matt we need some nformation for clarity. There is a form in the Radian section. Please complete that form with as much detail as you can. Just copy paste it into your reply. Be specific on the radio and receivers that you are using. Attach photos of you gimbal setup so that we can see your Radian wiring setup. Attach screen shots of the other Radian setting like you did for the tilt module. The reason form this request is that there are always multiple variables that can be causing the issue.
     
  10. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,366
    Likes Received:
    1,162
    Yeah. I agree with Gary -- the shots you've already taken show that everything is working correctly (which clearly is NOT the case!)
    You have Mode control on Channel 5 and only channel 5 is moving.

    Could you also (in addition to providing the other information), repeat those three images you sent, but this time do not operate the Mode switch on your transmitter -- instead take three images with the throttle at minimum, 50%, and maximum. I'm curious to see on the channel monitor whether the throttle is somehow causing change on channel 5. It should not be doing that, but that's the effect that you're describing.

    Those are not user selectable values. Those are the Radians reporting back to you what they are doing. The Radian connected to the Rx is reporting Spektrum (which is correct), and, between the first Radian and any other Radians, they use S.bus protocol.

    Sorry to make you do all this work, but it's really tough for us to tele-diagnose weird problems like this.

    Thanks
    Andy.
     
  11. Matt O'Brien

    Matt O'Brien Member

    Joined:
    Mar 16, 2013
    Messages:
    58
    Likes Received:
    1
    That is exactly what is happening when i move throttle in changes the mode. I will be able to take more pics when i get home
     

Share This Page