Radian Issue? Please read this first!

Discussion in 'Radian' started by Tabb Firchau, Jan 20, 2013.

  1. Adriana Mateos

    Adriana Mateos New Member

    Joined:
    Jan 29, 2013
    Messages:
    3
    Likes Received:
    0
    Hi there!

    The first thing I did was to upgrade the firmware to 1.03 <I thought I had already done it> and the twitch from the gimbal disapeared. Im so so so so so so so so happy!!!

    Thanks for all your tips

    adriana
     
  2. Andrew Goodwin

    Joined:
    Sep 23, 2012
    Messages:
    52
    Likes Received:
    0
    Hey there, got our new Radian and now we got the Pan and Roll working nicely. However, the Tilt is now unresponsive to slew command. Any suggestions?
     
  3. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    Andrew we need more information. Screen shots of the configuration screen for the tilt, description of your physical setup (photos would help), transmitter/rx being used.
     
  4. Andrew Goodwin

    Joined:
    Sep 23, 2012
    Messages:
    52
    Likes Received:
    0
    OK here they are. Using DX8 with Satellite.

    Quick question, should you be able to view input channel monitor from any Radian (and have the channels all respond green)? We only read this from the Pan Radian, everything is red from both other Radians. Note about setup: Servo going into 4, Shutter release going into 2, and Roll daisy chain going into 1.

    [​IMG]
     
  5. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    What channel on the TX are you using to control tilt?

    And you can only connect to one Radian at a time. You won't see the other Radians. Only the one attached.
     
  6. Andrew Goodwin

    Joined:
    Sep 23, 2012
    Messages:
    52
    Likes Received:
    0
    Hey Gary, thanks. We called QC and they got us sorted out. We had it daisy chained incorrectly.
     
  7. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,310
    Likes Received:
    1,153
    I was going to say, how come you have a daisy chain output on port 1? The outbound daisy chain should be on port 3.
    The reason I'm posting this is for future readers who might wonder what the solution was. :)
    Glad you got it sorted out, though, Andrew.

    Andy.
     
  8. Keith Colodny

    Keith Colodny Member

    Joined:
    Jun 22, 2013
    Messages:
    32
    Likes Received:
    6
    Just bought a cinestar 3 axis gimbal with Radian system. I bought it used and when it arrived it was mostly set up. After making sure all my connections were correct per Freeflys video, I tried to connect to the downloaded software but cant. Whenever I attempt to open software, I get this message before it opens "Error Opening comms port 10::Invalid Port Number". I installed the bootloader as well.
    Once open, I cannot connect. Any suggestions??
     
  9. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    Check in Win Manager to see what com port the Radian dongle is using and then change the Radian software to that port number.
     
  10. Grant Campbell

    Grant Campbell New Member

    Joined:
    Jul 22, 2013
    Messages:
    12
    Likes Received:
    0
    Aircraft Type: droidworks
    Gimbal Type: cinestar 360
    Radian Type ( 1, 2 , 3 axis) 3
    Gimbal Power source:
    Gimbal Radio Type: dx7
    Radian Communication Protocol (S.Bus, PPM, PWM, Spektrum) spektrum

    Connections: Change these to match your setup
    Roll Sensor:
    Port
    1.from pan
    2.
    3. To Tilt sensor
    4. To Roll Servo

    Tilt Sensor:
    Port
    1. from roll
    2.
    3.
    4. to tilt servo

    Pan Sensor:
    Port
    1.
    2. power
    3. to roll
    4. to pan servo

    Symptoms:
    I'm quite certain I've checked over the connections multiple times. If there's an error in the list above its because I've slogged over this for hours and can no longer think straight. But the connections are Out through 3, in Through 1, etc from Pan to Tilt to Roll (as described in the Videos and the Manual). My Spektrum receiver is plugged into Pan Radian.

    I get the "Error opening comms port10 :Invalid port number".

    Steps taken to resolve:
    I've opened Device manager and under Other Devices>FT32R USB UART> it says its on Port_#0001.Hub#0001.

    So I've gone into Radian software and switched to comm1. Error..invalid. I try 2. Error invalid, etc through every choice from 1 to 18.
    In each of these attempts, while plugged into any of the 3 radians I have yet to connect

    I'm attempting on a ASUS netbook:Windows7starter. I've tried both USB ports. I've connected a different USB device (Mouse) and after the computer automatically found the appropriate driver it works fine.

    I'm not super familiar with PC. I bought this computer today specifically to run this (and other helicopter software). So after failing for a while, I paralleled my iMac. Unfortunately I run into a "missing or invalid file" message.

    I've followed the list below and can not get past instruction B.

    Video of problem (this one is critical! If you can give us a good iPhone video with audio explaining what you are looking at we can usually resolve the problem very quickly. Please tell us what is going on in the video and at what time the issue happens.)

    Will try to make a vid tomorrow.


    Please also do the following:
    a. With the gimbal powered off, connect up the USB and adapter from your PC to the Radian sensor to which you have the receiver connected.
    b. Power on the gimbal and sensors with the transmitter set to the Off mode for the Radian sensors.
    c. Use the Radian software, connect the Radian cable to the Radian sensor connected to your receiver.
    d. Click on the Connect button to connect to the Radian sensor, and check you have a connection.
    e. Click on the Read button.
    f. Take a screen shot of the Diagnostic and Configuration windows and post it to this thread with your response to Question 1 above.
    g. Then connect up to the other two Radian sensors in turn, do a Read, and take a screen shot of the Diagnostic Window and Configuration Window and post those screen shots too.
     
  11. Scott Stemm

    Scott Stemm Member

    Joined:
    Apr 10, 2013
    Messages:
    140
    Likes Received:
    6
    Grant what language is your computer setup as?
     
  12. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    Grant doubt if you have a language problem since I think you are in Canada. Sounds like a USB driver issue. Go to http://www.ftdichip.com/FTDrivers.htm and find the proper driver for your Win7. Download the driver. In the Manage section where you can see the COM port if you double click it you can uninstall the driver on the driver tab. After you do that disconnect the Radian programmer, plug it back in and when it says it is looking for a driver manually point it to the driver you downloaded. Hopefully that will fix it.
     
  13. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,310
    Likes Received:
    1,153
    Grant:
    Also, find the Device Manager (under the Control Panel), and open it up. After you've installed the driver as Gary says, when you plug in the Radian programmer, you should see a new device appear under the COM & LPT section (that section might not even be there to start with if there are no other COM/LPT devices).

    But you have to get to the point where you see a USB device and a COM port number appear under the COM & LPT section in the Device Manager otherwise it means that Windows is not recognizing the Radian USB adapter.

    Bottom line: Right now this is a Windows software/driver problem unrelated to the Radian software but that has to be solved before you can get to the Radian software.

    Hope that helps
    Andy.
     
  14. Grant Campbell

    Grant Campbell New Member

    Joined:
    Jul 22, 2013
    Messages:
    12
    Likes Received:
    0
    Ok...I'm working on it. My computer is set to English (Canada) just to clear that point up.

    I'm 10 hours into my Windows experience and am near tossing the computer off a bridge...but that's another issue. Just reacquainting myself with PC and Windows after a 20 year hiatus.

    I think I'm making headway, thanks. I can at least see Ports (COM & LPT) now.
     
  15. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,310
    Likes Received:
    1,153
  16. Grant Campbell

    Grant Campbell New Member

    Joined:
    Jul 22, 2013
    Messages:
    12
    Likes Received:
    0
    Bada Boom. I've got a green servo out, which is good I think.

    Thanks Gary and Andy!
     
  17. Grant Campbell

    Grant Campbell New Member

    Joined:
    Jul 22, 2013
    Messages:
    12
    Likes Received:
    0
    Hazardous to my health is so true. Talk about high stress levels...I'm sure I just shaved a few days off my life.
     
  18. Grant Campbell

    Grant Campbell New Member

    Joined:
    Jul 22, 2013
    Messages:
    12
    Likes Received:
    0
    Thanks again! It's awesome you guys are here to help! Things are coming together. It took a little tinkering, but its not so bad. Seems to be doing what it should be doing!
     
  19. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
  20. Simon Orr

    Simon Orr New Member

    Joined:
    May 4, 2014
    Messages:
    4
    Likes Received:
    0
     

Share This Page