Radian Issue? Please read this first!

Discussion in 'Radian' started by Tabb Firchau, Jan 20, 2013.

  1. Adriana Mateos

    Adriana Mateos New Member

    Joined:
    Jan 29, 2013
    Messages:
    3
    Likes Received:
    0
    HI guys.
    thanks very much for all the quick answers. I=m gonna go through all of your tips and I tell you back.
    As andy has realized, all my versions <radian software, firmware and bootloader> are out of date, but I downloaded them thinking they where the latest version and they are not. I went here: http://www.freeflysystems.com/products/freefly-radian.php
    Then I founded this thread talking about the new updates on those
    http://forum.freeflysystems.com/index.php?threads/radian-firmware-1-03.450/
    I will updated from these link. But I think it will be better to have them updated on the web site.
    Ill report later!
    Thanks again.
     
  2. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    Adriana I sent a note over to Freefly this morning. Think it got out of sync with all of the changes of adding the new products. You did find the update spot.
     
  3. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,285
    Likes Received:
    1,148
    Ah.....the three position switch isn't doing what you think it is: It has three position: all Radians off, all Radians Stabilized Fixed (that is, tilt and roll keep the camera at a fixed position and horizontal respectively, and pan is locked), and all Radians in Stabilized Slew (that is, you can control pan and tilt, roll is just auto-level still).

    Do you have the copter suspended above your workbench by the battery plate? (Or the star plate if the gimbal is not attached to the copter).

    You must do this to simulate flight conditions -- if the gimbal's on the bench, the pan sensor is going to try and rotate the gimbal -- which, of course, it cannot do when it's on your bench.

    Do upgrade the firmware to 1.03 for all three Radians, though -- there is a known "noise/twitch" issue with the previous version.

    Andy.
     
  4. Andrew Goodwin

    Joined:
    Sep 23, 2012
    Messages:
    52
    Likes Received:
    0
    Hi Andy,

    Yes it started acting funny while suspended. Was working totally fine, then boom, pan went crazy. I've been terrified to upgrade the Radian firmware after reading through the threads for it and seeing so many people having issues with the upgrade. I shall try though. I'm back at it on Monday. When it comes to kopters, Murphy has me by the balls, so chances are, I'll have three little bricks on my hands.
     
  5. Andrew Goodwin

    Joined:
    Sep 23, 2012
    Messages:
    52
    Likes Received:
    0
    Actually Andy, quick question. The how-to video Tabb did for upgrading firmware shows the radian free of the gimbal. Is there a good process to do this with them still on the gimbal? Just unplug everything and away you go? He seems to be using something to power them up, I'm not sure what this is, would I be able to use the castle on the gimbal connected to a 3s qc 1200 lipo to do it?
     
  6. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    Andrew you can leave everything connected on the copter. Just plug the programmer into the pins 5+6 as normal. Supply power to the Radians just as you do in flight. Then check the programming. Since you are flying a 3axis you have a battery just for the gimbal and should be good to go.
     
  7. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,285
    Likes Received:
    1,148
    Err.....epoxy? :) Actually I just a good quality five-minute expoxy.

    Andy.
     
  8. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,285
    Likes Received:
    1,148
    When you say "pan went crazy" can you describe it in more detail? Uncommanded movements? Oscillating back and forth?

    Thanks
    Andy.
     
  9. Andrew Goodwin

    Joined:
    Sep 23, 2012
    Messages:
    52
    Likes Received:
    0
    Yep, uncommanded movements, back and forth. I had the pan working really great this morning and then it just seemed like a 'switch' went, and now when it turns on, just back and forth, no real pattern, just random, uncommanded oscillations.
     
  10. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,285
    Likes Received:
    1,148
    Still seems like it might be a noise problem. Once you have them upgraded see if the pan is still doing uncommanded random motion.

    Specifically check what's happening in the Diagnostic and Input Channel Monitor windows to make sure that nothing is moving back and forth there....

    If all is well, then it might be time to remove the Pan Radian sensor and replace it with one of the others to see if the problem goes away.

    Let us know what you find...

    Andy.
     
  11. Andrew Goodwin

    Joined:
    Sep 23, 2012
    Messages:
    52
    Likes Received:
    0
    Hey there, got all three Radians updated with the new firmware. Now nothing works :confused:

    Not sure if we need to re-bind, but from the PC software (the new one: Radian 1.1), The input channel monitor is showing all red channels.

    We're going to sleep on it. We are using a DX8 with the satellite, so not sure if there is a box we need to check that we're missing. Going to sleep on it and hopefully get somewhere with everything tomorrow.

    Just a note, the only input that seems to do anything from the DX8 is 'mode'. When it's in 3-slew mode, the pan is still doing the jerky, uncommanded movements.
     
  12. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,285
    Likes Received:
    1,148
    Hi Andrew:
    If the mode control is working, then there's no need to rebind the receiver -- that wouldn't be working if the Tx/Rx needs to be re-bound.

    I would start by simplifying things down:

    1. Use just the one Radian sensor that is connected directly to the receiver.
    2. Connect up the Radian software to that sensor.
    3. Verify in the Diagnostic window and the Input Channel Monitor window that your transmitter has control of the channels you need to it to have control of. If it does not, use the Servo monitor on the Transmitter to make sure that the transmitter is waggling the correct RC channels.
    4. Verify that this one Radian servo is responding correctly. For example, when the mode is Off, does the green LED flash slowly? When the mode is Stabilized Slew, does the green LED illuminate solidly?

    Only when you have got that first Radian sensor/servo working, worry about the others.

    Remember that, if you're working with the Pan Radian sensor/servo, that you need to power up the gimbal resting on the ground/bench to let the Radian sensors initialize, then suspend the copter by the battery plate so that the gimbal can turn rather than the copter turning -- this simulates flight conditions.

    Hope this helps
    Andy.
     
  13. Andrew Goodwin

    Joined:
    Sep 23, 2012
    Messages:
    52
    Likes Received:
    0
    Hey Guys, Got to this again this morning and still having problems. Here is a video of what is happening.
    Sorry about the out of focus video, was trying to get it on here in a hurry so we could get some help.

    Help please :(
     
  14. Andrew Goodwin

    Joined:
    Sep 23, 2012
    Messages:
    52
    Likes Received:
    0
    Here is a shot of what is happening with 'Current Angle Demand'. Not sure if this indicates a problem or not.
     
  15. Josh Lambeth

    Josh Lambeth Well-Known Member

    Joined:
    Jun 29, 2012
    Messages:
    1,312
    Likes Received:
    213
    Andrew, when you powered the gimbal up did you have it sitting perfectly still on the ground then you hang the copter?
     
  16. Andrew Goodwin

    Joined:
    Sep 23, 2012
    Messages:
    52
    Likes Received:
    0
    Yes. We power up on the bench, then hang it.
     
  17. Josh Lambeth

    Josh Lambeth Well-Known Member

    Joined:
    Jun 29, 2012
    Messages:
    1,312
    Likes Received:
    213
    When it's sitting on the ground what does the current angle read? Same thing?

    Try reloading the firmware to that radian. If that doesn't work try swapping it for a tilt or roll radian and see if the problem follows it.

    Josh
     
  18. Andrew Goodwin

    Joined:
    Sep 23, 2012
    Messages:
    52
    Likes Received:
    0
    Hey, thanks Josh. Reloading firmware didn't fix it. Going to re-locate and re-program the roll Radian on pan to see what happens there. I'll post again once I have more info tomorrow.

    Thanks for your help.
     
  19. Andrew Goodwin

    Joined:
    Sep 23, 2012
    Messages:
    52
    Likes Received:
    0
    Hey guys, OK, switched the Roll and Pan Radians up. Pan works perfect, and Roll is screwed up now. I'm assuming this means that we have a faulty Radian sensor that needs to be replaced?
     
  20. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    Sounds like a bad Radian. Contact your dealer.
     

Share This Page