Radian Firmware 1.03

Discussion in 'Radian' started by John Cunningham, Nov 19, 2012.

  1. John Cunningham

    Joined:
    Jul 5, 2012
    Messages:
    183
    Likes Received:
    13
    Glad I could help Cedric and sorry I couldn't do it sooner ....

    kjeti : which roll problem are you referring to ?. I'm not aware of a firmware issue - problems I have seen in roll are mostly due to the mechanical nature of the gimbal and balancing.
     
  2. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,285
    Likes Received:
    1,148
    Hi Cedric:

    Was the version that JohnC posted different to the one that I posted (See message #166 above)?
    I'm just curious why the version I posted did not solve the problem for you?

    (Soit dit en passant, est la boîte en carton sur son chemin? :) )

    Thanks
    Andy.
     
  3. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    I have to agree with John. Finally seem to have gotten my vibrations under control. Roll (145, 2 axis, black O rings, Nikon D800) was good but I was still getting jitters. Disconnected the tilt server and was nearly rock solid. Ended up setting the tilt gain all the way down at 30%. Now only a bit of junk and easy to scrub in Warp Stab at a 5% setting.

    Probably everyone is isolating the problem. Try a flight after everything is balanced carefully with Radians off. Then a flight with roll on. Check the outcome. Work on the roll gain until you are satisfied. Now tackle the Tilt the same way. And consider firming up the O rings depending on the weight of the rig you are flying.

    The progression of precision over the last year has been, frankly, astounding. I just looked back on Vimeo. Jeff did a video on using the MK FC board to control the 3 axis gimbal 10 months ago. We moved from that to Radians about 8 months ago. Earlier this month the MōVI was announced. With each iteration the camera platform got more stable. Wonder what we will see in the the next 12-18 months.
     
  4. Cédric Bourgoin

    Cédric Bourgoin Distributor

    Joined:
    Aug 21, 2012
    Messages:
    65
    Likes Received:
    5
    Hi Andy,
    the version available on the website didn't work nor the one you provided us :/
    Perhaps I made a mistake while upgrading with yours but I'm sur that the 34-99 worked well :)

    ps: Didn't I gave you the tracking number ?
     
  5. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,285
    Likes Received:
    1,148
    Hi Cedric:
    According to the file name, the version I uploaded should have been the same as the one JohnC uploaded.
    Bizarre.

    Let me check for the tracking number. It might have got mis-qualified as spam! :)

    Andy.
     
  6. Sylvio Rangel

    Sylvio Rangel Member

    Joined:
    Dec 6, 2012
    Messages:
    61
    Likes Received:
    0
    Anyone with this issue?

    Roll Radian's Orange Led keeps blinking fast when initializing.
    When starts-up "levelled" to the right side it initializes correctly and doesn't blink.
    When starts-up "leveled" to the left, does not initialize and orange led keeps blinking fast. In that case if I move the gimbal it finally initializes.

    It happened before and I swap Roll and Pan Radians. Now it is happening again....always in roll axis....wierd!!!!!
    Really need help here.

    Any idea?

    Tks, Sylvio
     
  7. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,285
    Likes Received:
    1,148
    I've not seen that problem before Sylvio....the evidence suggests that there might be an issue with the Radian, but the evidence (of swapping out to a different Radian) contradicts that.

    Just on hunch, I'd start wondering about the power supply -- it's it electrically noisy? Might it be injecting noise into the system?
    Sorry, I've got nothing more concrete than that to try, but the power supply seems to be a common factor for both Radians you've tried in the Roll position....that and the radio receiver/wiring.....not sure where else to go....

    Andy.
     
  8. Sylvio Rangel

    Sylvio Rangel Member

    Joined:
    Dec 6, 2012
    Messages:
    61
    Likes Received:
    0
    Hi Andy, tks for your respobse.....I will power the radian with a Nicd and see what happens.
    By the way, what is the Roll-1/roll-2 (either roll-1/roll-2 and tilt-1/tilt-2) difference? Is it for opposed radians mounting?

    I will post my "Nicd powered roll" result soon.

    Best Andy.
     
  9. Sylvio Rangel

    Sylvio Rangel Member

    Joined:
    Dec 6, 2012
    Messages:
    61
    Likes Received:
    0
    Andy,

    Same problem if powered by 4,8v Nicd or other battery.
    Download for video showing the issue..
    http://www.sendspace.com/file/il7an2

    Actions in that sequence....
    1-Roll leveled / Turn ON / green ON Yellow Flashes Fast / Slight pressure to level roll bar / RADIAN OK / Turn OFF
    2-Roll leveled to the right / Turn ON / RADIAN Init. OK / Turn OFF.
    3-Roll leveled to the left / Turn ON / green ON Yellow Flash Fast / Slight pressure to level roll bar / RADIAN OK / Turn OFF.
    4-Roll leveled / Turn ON / green ON Yellow Flashes Fast / Move Gimbal / RADIAN Init. OK / Turn OFF

    My conclusion: Always initializes fine when leveled to the right. When horizontal or leveled left it stops initializing right after power ON and ONLY proceeds with initialization after any change in RADIAN level position.

    I have reloaded FW 1.03 twice. I have changed all parameters. Issue remains.

    Tks,
     
  10. Sylvio Rangel

    Sylvio Rangel Member

    Joined:
    Dec 6, 2012
    Messages:
    61
    Likes Received:
    0
    Forgot....same problem if the RADIAN is alone or connected to the others.
    Same problem with or without receiver. Same problem with Tx OFF or ON, in both Stabilize or slew mode...
     
  11. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    Sylvio

    Can you post the video to YouTube or Vimeo? Comes up as part of iLivid and apparently wants to install an app to view even if I pick Presview. There's a lot us that won't install another app for security reasons. Would like to help but that is a bit of a bottle neck.
     
  12. Sylvio Rangel

    Sylvio Rangel Member

    Joined:
    Dec 6, 2012
    Messages:
    61
    Likes Received:
    0
    Hello Gary, here is the video on YouTube


    Sylvio
     
  13. Sylvio Rangel

    Sylvio Rangel Member

    Joined:
    Dec 6, 2012
    Messages:
    61
    Likes Received:
    0
    I got it sorted...RESET the Radian, "writing" without "reading" first...looks OK now.
    Thank you all.
     
  14. Ignatenko Alexey

    Ignatenko Alexey New Member

    Joined:
    May 24, 2013
    Messages:
    3
    Likes Received:
    0
    Good evening. Have a promlem with connecting a Redian module with Boot Loader software. Radian Stabilaze software works fine.
    So, I can't upgrade old firmware.
     
  15. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    Did you put the Radian into Bootloader mode with the jumper?
     
  16. Ignatenko Alexey

    Ignatenko Alexey New Member

    Joined:
    May 24, 2013
    Messages:
    3
    Likes Received:
    0
    Nope. First time hearing about this. Can you give me a link with pinout picture, and jumper place ? Thanks!
     
  17. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    See this video

    Whole series of videos on FreeflySystems YouTube channel.
     
  18. Ignatenko Alexey

    Ignatenko Alexey New Member

    Joined:
    May 24, 2013
    Messages:
    3
    Likes Received:
    0
    Thank, was help a lot !
     
  19. André Cousin

    André Cousin New Member

    Joined:
    Oct 19, 2012
    Messages:
    20
    Likes Received:
    0
    Hi Andy,

    Do you have intention to make a new version after this 1.03.
    Seem to me that this product is a (little bit) dead! Don't you?

    Regards.
    André
     
  20. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,285
    Likes Received:
    1,148
    Hi Andre:
    If your question relates to the fact that on the DVD I was using firmware 1.03 for the MX-20, the answer yes, you can now upgrade to version 4.0 HoTT of the firmware. Things have changed since I made the DVD, I am afraid.
    I'm sorry...I completely misunderstood your question -- you are referring to the 1.03 version of the Radian firmware....not the Graupner 1.003 firmware for the MX-20. Apologies -- it's late here (00:20).

    The problem is, given your question is about the Radian 1.03, as far as I am aware, that is the most current version of the firmware that Freefly has released.

    Did I understand your question correctly?


    Regards
    Andy.
     

Share This Page