my Knob thinks its a 2 position switch! Please help.

Discussion in '2 Axis Gimbal' started by Leopoldo Tamargo, Aug 27, 2014.

  1. Leopoldo Tamargo

    Joined:
    Apr 13, 2013
    Messages:
    61
    Likes Received:
    3
    Hello Everyone
    I'm trying to make use of my old 2 axis Freefly Gimbal that hangs under my Cinestar 6.

    I'm having a problem where when I turn the knob on my DX8 radio, that the gimbal goes either from looking straight down to looking straight forward or back the other way. There is no incremental adjustment. It just goes from one to the other or back.

    Now I am the one who set the max and min on this gimbal but what is happening is it just goes from one to the other whenever the knob reaches one certain point. In this case it is "171" on the readout from MK Tools.

    In the Channels tab of MK Tools, it reflects and incremental movement as I turn the knob. It does not however move the gimbal the same way. When the numbers reach around "171" it changes immediately from one position to the other.

    I'm planning on getting a larger Cinestar 8 soon to use with my M10 (hope to become M15!).

    For now however I would like to just get this one working for some low end still work I have coming up.

    I have updated the firmware to the latest as well as the latest MK tools.

    As these things go, it used to work fine and I'm not sure what changed.

    Any help would be appreciated.

    Thank you
     
  2. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    Leopoldo the way the Radians work the knob needs to come back to Center (zero value) to stop movement. It does not work as if you set the knob to 45 degrees up that the unit will tilt to 45 degrees and stop. So you just need to start and stop the tilt with knob being rotated and then back to the Zero value. Similar to a self centering stick on the DX8.
     
  3. Gary McCready

    Gary McCready Active Member

    Joined:
    Oct 26, 2012
    Messages:
    284
    Likes Received:
    42
    You must have Radians? I ended up moving mine to a 3-way switch. Power up in the middle position, push it up goes up, to stop move it back to middle. I set it up with expo too, to slow it down, but it is still just one tilt speed.
     
  4. Leopoldo Tamargo

    Joined:
    Apr 13, 2013
    Messages:
    61
    Likes Received:
    3
    Thank you for the response.

    Sadly these are servo's and not Radians.

    I feel the answer is obvious, just not to me.

    It worked before, I hadn't touched it in a long time, I updated all the firmware on the Cinestar six and now it either looks forward or down when I turn the knob.

    Any help is appreciated.

    Thanks
     
  5. Leopoldo Tamargo

    Joined:
    Apr 13, 2013
    Messages:
    61
    Likes Received:
    3
    One more thing that might be related. In the past, If I was to turn off the radio with the copter still powered the copter would warn and the gimbal would flop. When I turn off the radio now I get the copter warning and the gimbal flops but then when I turn the radio back on the gimbal comes back to attention.
     
  6. Jason Smoker

    Jason Smoker Active Member

    Joined:
    Oct 23, 2012
    Messages:
    830
    Likes Received:
    65
    your running the servos through the fc?

    Try clicking the Servo relative button under the camera tab.
     
  7. Leopoldo Tamargo

    Joined:
    Apr 13, 2013
    Messages:
    61
    Likes Received:
    3
    Yes I am.

    I will try that tomorrow morning. Thank you very much!

    Leo
     
  8. Jason Smoker

    Jason Smoker Active Member

    Joined:
    Oct 23, 2012
    Messages:
    830
    Likes Received:
    65
    Yeah I not 100 percent sure on that one but I just remember reading it on the mk wiki somewhere that with servo gimbals you needed that clicked.
     
  9. Leopoldo Tamargo

    Joined:
    Apr 13, 2013
    Messages:
    61
    Likes Received:
    3
    I clicked on "Servo Relative" and the response was that the gimbal would try to tilt when I gave it input to do so but would actually only "Chatter" a bit until I stopped giving it input.
     

Share This Page