MX-20 Neutral stick accelerates UP in 2.0 update

Discussion in 'Cinestar 6' started by Gary McCready, Oct 4, 2013.

  1. Gary McCready

    Gary McCready Active Member

    Joined:
    Oct 26, 2012
    Messages:
    284
    Likes Received:
    42
    I'm having a problem with my CS6 accelerating up with the stick in the center (spring in) position. With AH "on" it is fine but as soon as I turn it off the heli rises fast, sometimes real fast. Didn't happen in .88. Only other thing changed in MKTools was the "Min gas": 32 and was 45? I saw another post about this on the MiKrocopter board, so I guess I'm not the only one. Thinking of reverting as this is getting tiring trying to figure out why things are screwy with 2.0 .
     
  2. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    Gary I think the Min Gas default is a value of 8. You can read about what the value does either on the MK Wiki or at mkmanual.com. I would try going back to an 8 setting and see if that helps. Also make sure in your transmitter that somehow a throttle curve has been applied or the RC type hasn't changed from airplane to helicopter.
     
  3. Adam Paugh

    Adam Paugh Distributor

    Joined:
    Jun 29, 2012
    Messages:
    323
    Likes Received:
    78
    Hello Gary,

    Check the "Stick neutral point" the the EASY SETUP tab. For spring loaded throttle (mode 0) it will need to be valued at "127" and not "0--automatic"

    There also may be some interplay issue with the auto-take off and landing as featured in SW: 2.0

    Greetings,
    Adam
     
  4. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    And one other item to check is the stick calibration just to ensure that the sticks are doing the right values.

    And when you fly manually if you find that the hover point with the sticks is below center then when you have it at center in AH and turn AH off the sticks are higher than your normal hover.

    I have the opposite issue. Hover is above center. When I turn AH off I need to simultaneously add throttle otherwise the copter starts to descend.
     

Share This Page