Movi M5 doesn’t work : stabilization and mapping problems

Discussion in 'MōVI M5' started by Cyrille Vaillant, Mar 16, 2016.

  1. Cyrille Vaillant

    Cyrille Vaillant New Member

    Joined:
    Oct 29, 2014
    Messages:
    4
    Likes Received:
    0
    I’m coming to you because I hope the community can help to solve this problem. I have submit a ticket but at this time nobody have found something to help me.

    I have the Movi M5 since a lot of month, the Movi have never worked properly. I try to have a good stabilization with a GH4 + 12mm Olympus on my X8 octocopter with a remote controller or only with the follow mode. There is simply no stabilization, it’s like on a boat: the roll, the pan and the tilt are absolutely not fixed. At first I thought it was a vibration problem. I have good balanced all props, changing the o-ring red by the blue, check the good balance of the movi and after all that the problem is still there.

    After that I spend a lot of time to try a lot of swiftness tuning, with no good result. After making some test with my Rc controller Futaba 14SG and 8J, I have fund a really weird problem: when I make a roll trim, the Movi make a pan with the roll. This is more important when the tilt is down or up. My first thinking was there is a mixed mapping on my controller but after making a lot of mapping test with two controllers the problem is still there. I have start with clean and new plane or helicopter model with no mixed program and the problem is still there. I have test custom mapping, user manual mapping, quadrocopters mapping () and finally freefly model setting file on a sd card that the support send me, and the problem is still there : when there is a roll trim there is a pan with it, or when the roll trim is set at the max, when I do a pitch there is a roll and a pan with it. It's like there is a really weird program mix or a IMU error.

    The Freefly support say me that it’s a problem of mapping settings, but I have try every mapping possibilities. I have a lot of multicopters and I have built a lot gimbal with alexmoss or phobotic controllers. I’m not a beginner, but not a freefly expert. One day I had a similar problem with a phobotic gimbal and it’s solved by attaching correctly the IMU (if it’s not centered and at the level the roll could be mismatched with the pan and the tilt), maybe the problem is the same or worth.

    Futhermore a mapping settings problem do not give stabilization problem on a majestic mode with no rc controller. Maybe there is two problems, but after all my test I’m really thinking there is a hardeware problem.
    You can see on this video the problem: . At first I try the Futaba model file sending by the freefly team for a good mapping and at the end you can see some footage of the gh4 on the movi in majestic mode or dual operator mode in the air.

    At this time I really need some help. This problem is very weird. I have spent a lot of time and money for a high end technology that doesn’t work. If someone have an idea, I shall very grateful.

    Thanks a lot!

    Ps: Sorry for my English.
     
  2. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    Cyrille, what values do you have for the various stiffness settings (tilt, roll, pan)? Also have you watched the MoVI gui screen where you can watch the control inputs to make sure that a single RC control movement isn't moving multiple channels in the MoVI?

    In the video I can't tell what control you are touching to introduce the roll? Was it the trim button?
     
    Chris Harrison likes this.
  3. Cyrille Vaillant

    Cyrille Vaillant New Member

    Joined:
    Oct 29, 2014
    Messages:
    4
    Likes Received:
    0
    Gary, thank you for your reply.

    After an auto tune the stiffness values are 76 for the pan, 26 for the roll and 5 for the tilt.
    In expert mode Pan tilt roll strength: 8
    gyro filter: 5
    Output filter: 5
    shaky cam pan and tilt: 0
    declination: 0

    Yes the control in the video for the roll trim is the Futaba J4 trim T4. Chris Harrison sent me the Movi futaba model file which I have put on a SD card. I have used this profile in the video. I am sure there is no multiple channel moving on the chart, only the roll trim channel is moving. But as you can see in the picture of the motor charts, the charts of the roll's motor and of the pan's motor work together when I use the roll trim.

    Cyrille.
     

    Attached Files:

  4. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    Try dropping the two filter settings to 3. That should help raise the stiffness values. Take a look through the forum with a search on folks using a similar camera. Looks like you have a GH4. They are tough to get balanced. There are posts that talk about adding weight to give better results.
     
  5. Brad Meier

    Brad Meier Active Member
    Staff Member

    Joined:
    Aug 14, 2012
    Messages:
    749
    Likes Received:
    66
    I think you have a few problems going on from the limited ability to diagnose from the forums.

    1. The way the IMU is mounted, the IMU calibration, or some form of mixing in the radio is causing the pan/roll coupling. Since you've gone through the radio mixing possibility, its most likely the IMU. And since you have an M5 and the IMU mounting is fixed, thats likely not the issue either. I would say something could've happened during the IMU calibration. That would be something for Freefly to handle. Now this diagnoses it really just a guess based on my experience.

    2. As for the aerial video, that looks like a combination of things. Your gain settings look about where they should be and adjusting numbers in filters probably won't give you a marked improvement in footage quality. For the most part I would say thats aircraft vibration, poor mounting, vibration isolation issues. The IMU could be affecting it as well but not as much as the other issues.

    Just my thoughts.. but what do I know... I only worked there and film professionally. ;)
     
    Chris Harrison likes this.
  6. Graham Futerfas

    Graham Futerfas Well-Known Member

    Joined:
    Oct 19, 2015
    Messages:
    1,233
    Likes Received:
    239
    Hi Cyrille,

    For what it's worth, if my M15 is tilted down and I Roll the camera, it will pan a bit as well as roll, very much the same as yours. If my camera is pointing straight out, it will Roll without Panning.
     
  7. Cyrille Vaillant

    Cyrille Vaillant New Member

    Joined:
    Oct 29, 2014
    Messages:
    4
    Likes Received:
    0
    Thanks a lot for your replies. I have done some new tests with other filters and stiffness values and the stabilization quality remains not good. I think it's probably a IMU problem. I will send back my MoVi to RMA thanks a lot for the Freefly support.
     
  8. Cyrille Vaillant

    Cyrille Vaillant New Member

    Joined:
    Oct 29, 2014
    Messages:
    4
    Likes Received:
    0
    Hello, the freefly's support team have my MoVI. Now I understand : The MoVi doesn't support the roll trim !! It's not a IMU problem, a mixed channel setting on my controller, a bad mapping on the app. This fonction is just not supported. I don't understand why on the user manual they say to map the roll trim on channel 4 for futaba controller if it doesn't work properly ! Yes it's possible to do a roll trim but it will act on the pan and on the pitch like on my video clip. I have pay the transport to USA and to France only for understand this. It's hurt a little.
    For the bad stabilization, I will work a little more for founding the good tuning and I will not be able to correct the horizon when it drift or for making some visual effect...
     

Share This Page