Motor start sequence with Graupner MX-20

Discussion in 'Cinestar 8' started by alec_caton, Jan 8, 2013.

  1. alec_caton

    alec_caton New Member

    Joined:
    Nov 19, 2012
    Messages:
    19
    Likes Received:
    0
    Hi.

    We've recently bought and built a cinestar 8 (following Andy's DVD to the tee) and we've had a couple of successful test flights, but recently we've had a problem starting the motors with the MX-20. It appears the start sequence is throttle down, yaw right + nick back.

    At some point we think we've changed the sequence of the motor as durng our last test, with the motors off the control were operated (accidentally) but the cinestar acknowledged a command and beeped. Ever since the start up/idle sequence is different. It also seems to want to accelerate in the nick axis.

    We've been trawling the net and doing our research but we seem to have come to a dead end. We think we may have changed to a different setting (?) which we're going to look into, but if anyone has any idea what we've done your help would be much appreciated!!

    Cheers
    Alec
     
  2. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    MK start motor start is throttle in lower right corner. Motor off is throttle in lower right corner.
     
  3. Dave King

    Dave King Well-Known Member

    Joined:
    Dec 24, 2012
    Messages:
    2,711
    Likes Received:
    311
    YOu want to make sure all your stick trims are centered in MKtools. You can verify this by going to the channels tab and centering both of your joysticks. Channels 1 through 4 should be in the center detent position. You should then take each control to the min and max and make sure that it is responding correctly. 3 of my 4 channels needed reset. I went into the MX20 settings and reset it everything and it didn't help. The only thing I could to fix the problem was to create a new program.
     
  4. alec_caton

    alec_caton New Member

    Joined:
    Nov 19, 2012
    Messages:
    19
    Likes Received:
    0
    Thanks for the quick responses!

    Gary, when we initially set-up our start up and shut down was as you said (ON/throttle lower right, OFF/throttle lower left) however it appears I've reprogrammed this through the MX-20, do you know if it is possible to do this? Just so I know for future reference!

    And Dave, thanks for the input! I'll create a new program as soon as!
     
  5. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,375
    Likes Received:
    1,162
    Hi Alec:
    I was looking at the source code for the Flight Controller the other day and I don't think it the FC is expecting anything other than left stick to the 4:30pm position on the clock (back and right) for motor start.

    You could look at the MX-20 Servo monitor screen (with the C8 powered off) and see what's actually happening in terms of the servos, or, remove the props from the C8, power it up and connect up with MK Tool and look at the Channels Window (click on Settings) and examine what the actual RC channels are doing.

    Hope this helps
    Andy.
     
  6. Dave King

    Dave King Well-Known Member

    Joined:
    Dec 24, 2012
    Messages:
    2,711
    Likes Received:
    311
    I think this will change if you change the stick mode from 2 to 1
     
  7. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,375
    Likes Received:
    1,162
    That's a good point.
    Alec: Check page 61 of the MX-20 manual -- Basic Settings, Model. Did you get the MX-20 into Mode 1 by accident?
    Of course, if you're in Europe, you may choose to have it in Mode 1 as Dave says.

    Andy.
     
  8. alec_caton

    alec_caton New Member

    Joined:
    Nov 19, 2012
    Messages:
    19
    Likes Received:
    0
    Hi guys,

    Thanks for all your help, its very much appreciated. So far we've set up a new model in Graupner and made sure the stick mode is 2, We've been into MK tools and reset to default, making sure the setting is 3 (Setting 3 = basic flight attitude) and written and saved everything. Unfortunately to no avail. We're just checking all the Graupner channels to see if they are responding correctly, which they appear to be, however now we do not have any way of motor start/idle :(

    Bad times.
     
  9. alec_caton

    alec_caton New Member

    Joined:
    Nov 19, 2012
    Messages:
    19
    Likes Received:
    0
    Update:

    After everything we have reset, we've just taken the rig outside for a test and began by calibrating the compass, which no longer accepts left stick to upper left with right stick down followed by a second right stick down to start the procedure. Instead the procedure was activated by BOTH left and right stick down followed by a second right stick down action.

    Any ideas? Or has anyone experienced similar?
     
  10. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,375
    Likes Received:
    1,162
    Have you got any RC channels reversed, I wonder?

    Using MK Tools -> Settings -> Channels, can you verify that the following:

    What you see is:
    Left stick: back, channel 1, close to zero (e.g. 5) / forward, close to 255 (e.g 253)
    Right stick: back, channel 3, close to zero / forward, close to 255
    Left stick: left, channel 4, close to 255 / right, close to 0
    Right stick: left, channel 5, close to 255 / right, close to 0

    Can you confirm that this is what you get?

    Andy
     
  11. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,375
    Likes Received:
    1,162
    Can you also confirm that you set up an Aircraft model, not a Helicopter model?
    Thanks
    Andy
     
  12. alec_caton

    alec_caton New Member

    Joined:
    Nov 19, 2012
    Messages:
    19
    Likes Received:
    0
    Hi Andy,
    Yeah we are set up as an Aircraft model and all channels are correct to what you have listed.
     
  13. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,375
    Likes Received:
    1,162
    That's the WRONG answer Alec.... :)
    Now I have to sit and think.....well, maybe I'll just sit...... :)

    Time for the nuclear option, perhaps?
    MK Tool, Settings, bottom of the screen, red triangle with exclamation mark. Click it and it resets all the MK Tool parameters back to default. Click on Write to send the values out to the MK Boards.

    Andy.
     
  14. alec_caton

    alec_caton New Member

    Joined:
    Nov 19, 2012
    Messages:
    19
    Likes Received:
    0
    We've just double checked the channel information you've given us and it appears the Graupner MX-20 was set to the channels above but in MK Tools the channels were inverted. The channel mode had changed but the Graupner was still displaying mode 2 which is what had mislead us!

    Thank-you very much for your help! we appear to be able to get the motors started and stopped according to the default stick settings.
     
  15. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,375
    Likes Received:
    1,162
    Glad you solved it.
    You had me worried as to what to try next.

    Andy.
     

Share This Page