Mk motor shut down

Discussion in 'Electronics' started by Michael comissiong, Sep 19, 2013.

  1. Gustavo Rios

    Gustavo Rios Member

    Joined:
    Sep 28, 2012
    Messages:
    236
    Likes Received:
    3
    Hi Michael,
    Hi Dave, I have a DX8, I try but the throtle channel stay in the center, no down.

    Gustavo.
     
  2. Gustavo Rios

    Gustavo Rios Member

    Joined:
    Sep 28, 2012
    Messages:
    236
    Likes Received:
    3
    Check this:

    INFO:
    The emergency gas is only active when a gas value was >40 for at least 4 seconds. This means the copter is flying!
    If the copter stay on the ground, you start the motors and switch off the transmitter, the motors will stop immediately and the function emergency gas is not working!

    Now, how I can try this without the risk of flying ?, from the second floor ?

    Gustavo.
     
  3. Dave King

    Dave King Well-Known Member

    Joined:
    Dec 24, 2012
    Messages:
    2,711
    Likes Received:
    311
    Gustavo

    Gas value at hover is 127 so if you simply start the copter with no props on and put both sticks to the center position, all sticks values will be 127 including the gas value. So you don't actually have to fly it to test it.

    1. Take the props off
    2. Hook up the copter to MK tools and channels
    3. Start the copter and then let go of both sticks to their center position.
    4. Shut the radio off
    5. Watch what happens to channel 1 which is the gas value.

    With the Specktrum DX8 there are 3 different fail safe modes you can use in the radio. If your test shows that the gas goes to 0 I can tell you how to set it up so that the gas value in fail safe.
     
  4. Gustavo Rios

    Gustavo Rios Member

    Joined:
    Sep 28, 2012
    Messages:
    236
    Likes Received:
    3
    Hi Dave,

    The channel 1 not go to 0, but I try with the copter in the hands and "voila", apparently the failsafe activates because I have red light and the motors do not stop, now is the only way to prove it?
    I try this:

    1. Turn on radio
    2. Start the copter
    3. Stick gas to the middle
    4. I take the copter with the hands and raise it as if it was flying
    5. I shut the radio off

    Now, Is it the only way of proving that the failsafe works?

    Gustavo.
     
  5. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,383
    Likes Received:
    1,164
    Good suggestions, Dave. The Graupner "Failsafe" might be "Failing Not So Safe."

    Andy.
     
  6. Dave King

    Dave King Well-Known Member

    Joined:
    Dec 24, 2012
    Messages:
    2,711
    Likes Received:
    311
    HI Guestavo

    No its not the only way but its the only way you will be able to safely test it without crashing it if the value goes to 0. You don't need to pick up the copter like it is flying. You don't need to simulate a flight and you can leave it on the ground. All you need to do is start it up, the copter doesn't care if its on the ground, or 10 feet high. Just have the motors spinning like they normally would as if the copter has a gimbal on it and it has props on ready to take off. When you have the copter's motors running the MK is working just like it would in flight. The only difference is you don't have props on it and it's on the ground not in the air.
     
  7. Dave King

    Dave King Well-Known Member

    Joined:
    Dec 24, 2012
    Messages:
    2,711
    Likes Received:
    311
    Andy, Gustavo is using a Spektrum DX8. By default, you are setting the fail safe functions when you bind the radio. You really don't have a choice to have fail safe off. When you bind it you are supposed to bind it with the stick in the down position. When you bind the DX8 you have to hold the bind/train button down and then turn the radio off. If you tried to do this with the stick in the center position the radio will send off a warning and it will not bind. I got around this by turning off the high throttle warning on startup in the warnings settings.
     
  8. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,383
    Likes Received:
    1,164
    Oh yeah...I remember reading about that "throttle not at zero" style warning....
    Andy.
     
  9. Michael comissiong

    Joined:
    Feb 9, 2013
    Messages:
    59
    Likes Received:
    4
    Hi All,
    tried Dave's suggestions but no luck , motors still shut down when signal loss induced.
     
  10. Gustavo Rios

    Gustavo Rios Member

    Joined:
    Sep 28, 2012
    Messages:
    236
    Likes Received:
    3
    Hi Michael, try this :

    1. Turn on radio
    2. Start the copter
    3. Stick gas to the middle
    4. I take the copter with the hands and raise it as if it was flying
    5. I shut the radio off

    Gustavo.
     
  11. Dave King

    Dave King Well-Known Member

    Joined:
    Dec 24, 2012
    Messages:
    2,711
    Likes Received:
    311
    Michael

    What exactly did you do? Can you confirm what happened in MK tools with the throttle channel when you turn the radio off?
     
  12. Michael comissiong

    Joined:
    Feb 9, 2013
    Messages:
    59
    Likes Received:
    4
    Hi All
    problem solved
    Graupner did change the FailSafe function in the receivers. If you use the latest Software on your receiver you have to go into the Menue "Setting & Data view".
    There go to the window "RX Fail Safe Vx.xx" and change the "MODE" of channel 1 to "OFF". Now the copter will again receive the lost signal.

    Mit freundlichen Grüßen / Best regards

    Lothar Freudenberg

    HiSystems GmbHem .

    I had upgraded all my rx/tx graupner stuff after my swimming pool incedent they just did not mention the above.
     
  13. Dave King

    Dave King Well-Known Member

    Joined:
    Dec 24, 2012
    Messages:
    2,711
    Likes Received:
    311
    Michael

    The change of the Graupner menu settings will allow the MK flight control board to go into fail safe mode. I thought the issue with this copter was that when it goes into fail safe the throttle goes to 0. Can you confirm that your copter was going into fail safe or were you not sure?
     
  14. Michael comissiong

    Joined:
    Feb 9, 2013
    Messages:
    59
    Likes Received:
    4
    Hi Dave,
    my issue was that when I induce fail safe by turning off my radio the MK Motors completely shut off , thus if flying will fall out of sky.
    the throttle looking at it in the mk tools dose not move at all

    With the change from Luther when I induce the FS the MK response is as it should be , gose into FS mode etc. motors do not shut down.
     
  15. Gustavo Rios

    Gustavo Rios Member

    Joined:
    Sep 28, 2012
    Messages:
    236
    Likes Received:
    3
    Hi Dave, I need to make the bind again to have the active failsafe ?
     
  16. Dave King

    Dave King Well-Known Member

    Joined:
    Dec 24, 2012
    Messages:
    2,711
    Likes Received:
    311
    I'm a bit confused I thought you were using Spektrum DX8 not graupner? With graupner you don not need to rebind. With Spektrum you need to bind the radio to determine failsafe default values.
     
  17. Gustavo Rios

    Gustavo Rios Member

    Joined:
    Sep 28, 2012
    Messages:
    236
    Likes Received:
    3
    Yes, I have a dx8 with spektrum satellite.
     
  18. Gustavo Rios

    Gustavo Rios Member

    Joined:
    Sep 28, 2012
    Messages:
    236
    Likes Received:
    3
    Hi Dave, The DX8 has to bind of another way ?

    Gustavo
     
  19. Dave King

    Dave King Well-Known Member

    Joined:
    Dec 24, 2012
    Messages:
    2,711
    Likes Received:
    311
    What do you mean another way to bind? There's only one way to bind the receiver to the TX and you are setting up the fail safe parameters when you bind (unlike Graupner).
     
  20. Gustavo Rios

    Gustavo Rios Member

    Joined:
    Sep 28, 2012
    Messages:
    236
    Likes Received:
    3
    Ok Dave, you can help with the dx8 settings for failsafe?
     

Share This Page