MK FC 2.5 +FW 2.10 + Hercules 3 i2c error

Discussion in 'Cinestar 8' started by Mihkel Kuningas, May 11, 2015.

  1. Mihkel Kuningas

    Mihkel Kuningas New Member

    Joined:
    May 11, 2015
    Messages:
    12
    Likes Received:
    2
    Hello all!

    Was upgrading to fw 2.10 lately and was making test filghts and suddenly got error 17 and 18 i2c error+bl missing.
    Checking from GPX log BL 13 is missing but i am using only 8 motors.
    Allso replaced all cables molex+serial - it appears suddenly and then goes.

    Does anyone had this problem?
     
  2. Steve Maller

    Steve Maller UAV Grief Counselor

    Joined:
    Oct 30, 2012
    Messages:
    3,979
    Likes Received:
    807
    Did you re-set all your settings on the property pages in MK-TOOL? Upgrading firmware sometimes makes a mess of your settings. And do not save/restore your settings from a file. Some firmware upgrades change the structure. The best approach is to do a screen capture of each of the settings screens, then re-enter everything by hand.
     
  3. Mihkel Kuningas

    Mihkel Kuningas New Member

    Joined:
    May 11, 2015
    Messages:
    12
    Likes Received:
    2
    Hi!

    Thanks for your answer - yes i saved profile before and then loaded it after to new fw - i never had this issue before.
    I may try delete all and make new config after manually.
    What did you mean by re-setting software? Eraseing.ini files?
     
  4. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,371
    Likes Received:
    1,162
    I agree with Steve. When you save the MK Tool settings to a file, upgrade the firmware, and reload from the saved file, there is a real risk that some settings might have got mangled...

    You have a choice: before you upgrade you can either: 1) save the current MKTOOL settings to a file and/or 2) make screen shots of every MKTOOL page.

    The file you save to disk will be a regular text file....so you can see ALL the parameters and all the values to which they are set. The screen shots, obviously show you the settings as they appear in MKTOOL.

    What I do is:
    1. Save the MK Tools setting to a file (e.g. File name: Settings before upgrade 2015-05-11 1055.mkp. Note date and time in file name just to reduce the risk I get confused -- I confuse easily :) )
    2. Do the upgrade.
    3. Save the MK Tools settings to a file a second time (e.g. File name: Settings after upgrade 2015-05-11 1055.mkp)_
    4. Open up both files in a text editor (or print them out) and then do a line by line check to make sure nothing has changed.
    5. If anything has changed, then use MKTOOL to set the values back to what they should be.

    Hope this helps
    Andy.
     
  5. Mihkel Kuningas

    Mihkel Kuningas New Member

    Joined:
    May 11, 2015
    Messages:
    12
    Likes Received:
    2
    what was allso confusing to me is that usually when i upgrade FW MK tells me to calibrate ACC and Compass. But this time it didnt.
    Before with older upgrades when i forgot to calibrate acc and magnet sensor then MK gave me ´´error calibration´´ message but not this time...
     
  6. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,371
    Likes Received:
    1,162
    That is strange. I wonder whether the guys at MK have found a way not to destroy the previous firmware's ACC and compass settings when you do a firmware upgrade?

    Andy.
     
  7. Mihkel Kuningas

    Mihkel Kuningas New Member

    Joined:
    May 11, 2015
    Messages:
    12
    Likes Received:
    2
    I contacted them.. i think this was (no need for calibration)because i saved and loaded old settings from last FW - i upgraded 2 weeks ago to 2.10:) I delete all and enter manually. But MK sayd this I2c problem is not caused because of that. We can see.
     
  8. Mihkel Kuningas

    Mihkel Kuningas New Member

    Joined:
    May 11, 2015
    Messages:
    12
    Likes Received:
    2
    PS! I changed to other herkules now (i have 2) and go for test flight soon so then i can see is this problem still exist.
     
  9. Mihkel Kuningas

    Mihkel Kuningas New Member

    Joined:
    May 11, 2015
    Messages:
    12
    Likes Received:
    2
    After herkules change.. no error.. but i ALLSO changed serial ribbon cable - that could cause allso problems - soon swich back and try with new ribbon cable to see does the problem still exist:)
     

Share This Page