Drive Initialisation failure

Discussion in 'Radian' started by Chris Loughlin, Oct 3, 2013.

  1. Chris Loughlin

    Chris Loughlin New Member

    Joined:
    Oct 3, 2013
    Messages:
    1
    Likes Received:
    0
    Aircraft Type: SkyJib8 (though on a C-Stand rig for testing)
    Gimbal Type: Cinestar 3 Axis
    Radian Type: 3 axis
    Gimbal Power source: 11v LiPo via 5v BEC
    Gimbal Radio Type: Spektrum Dx6i
    Radian Communication Protocol: Spektrum

    Connections:
    Pan Sensor:
    1. Power from 5v BEC
    2.
    3. Lead to Roll Radian
    4. Pan Servo
    Spektrum Satellite Radio (9645) plugged into side port

    Roll Sensor:
    1. Power/Signal from Pan Radian.
    2.
    3. To Tilt sensor
    4. To Roll Servo

    Tilt Sensor:
    1. Lead from Roll sensor
    2.
    3.
    4. To Tilt servo

    Problem:
    I've just Installed 3 Radians on the Cinestar Gimbal using a Spektrum satellite radio.
    Pan and Roll systems all work fine. No problems at all. The Tilt Radian fires up, rotates the servo briefly and then stops with slow flashing green light. (ie Drive Initialisation Failure?) This happens even when the mode switch is on - and the other Radians stop their green "Motor off" flashing.

    The Orange Radio/Signal light is steady on all three – and the Roll and Pan Radians respond correctly to Mode switch and Slew (Pan only).
    Steps taken to resolve:
    I connected the TILT servo motor to the ROLL Radian – and it appeared initialised correctly (though w/o feedback, the camera bracket rotated continuously).
    I then connected the ROLL servo to the TILT radian – that also appeared to initialise correctly.
    I connected an old Hoverfly board to the Tilt servo – and that worked fine.
    I swopped resistors on the Roll and Tilt servos and that made no difference.

    So all servos and Radians appear to be working ok – but just that the Tilt Radian doesn’t seem to like its correct servo.

    I tried it with the Spektrum Satellite directly into the Tilt Radian and with power directly to port 1 and the servo on Port 3. No change. Still a steady orange and a slow flashing green.

    The Radio side all seems to be working fine – I can slew the Pan and the roll adjusts itself. I can also turn both off with the mode switch. I can see the input slew on the Tilt channel – but the Servo Out, though green – doesn’t move.

    Any suggestions? Is it worth (re)flashing the firmware on the suspect Radian? (Though they were all on V1.3 on delivery). Any/All suggestions gratefully received!

    Screen shots of all three config/monitor software readouts attached:
     

    Attached Files:

  2. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    I would do the firmware reinstall next.
     

Share This Page