Cinema Robot does not connect with Google Pixel 2

Discussion in 'Movi Technical' started by Hussain Suff, Mar 4, 2019.

  1. Hussain Suff

    Hussain Suff New Member

    Joined:
    Feb 1, 2019
    Messages:
    1
    Likes Received:
    0
    Hi all,

    I was hoping someone could offer me some help or guidance. I recently purchased a Movi Cinema Robot and tried to pair it with my Google Pixel 2 128GB and when I run through the app, it persistently displays the 'Turn cinema robot on' message to pair, even though I have the Cinema Robot on and not in sleep.

    I've subsequently tried with another Cinema Robot bought brand new and no luck either and tried it with 2 other Google Pixel 2 devices and still the same error. I manage to connect with my Galaxy S7 but never with my Pixel 2 devices. I suspect there's a firmware or software issue between the phones and cinema robot. I also managed to upgrade the firmware on the cinema robot using my S7 but still no luck.

    I can see that the Pixel 2 is listed as being compatible and other users have been able to connect, but not sure what I can do to rectify the issue.

    Any help would be greatly appreciated :)
     
  2. Rob Bach

    Rob Bach New Member

    Joined:
    Mar 5, 2019
    Messages:
    2
    Likes Received:
    0
    Same issue with my Pixel 2xl
    1. Movi is displayed in available bluetooth devices, but pairing just blinks and no connection.
    2. My old Microsoft phone and laptop will pair with the movi.
    3. My pixel 2xl will pair with an audio device.

    I tried the 4 AVRCP versions 1.3 to 1.6.. nothing.
    Someone mentioned that the Pixel 2 had a hardware issue & your luck of
    the draw whether you got the faulty chip. No idea if there is any truth to this.
     
  3. Rob Bach

    Rob Bach New Member

    Joined:
    Mar 5, 2019
    Messages:
    2
    Likes Received:
    0
    was just on my way to take my Pixel 2 back to the store... Tried movi one more time and
    voila.. it connected. Not sure what I did.. after 50 plus tries.. but my AVRCP setting was 1.6.. make sure
    to power off. And I turned on my location settings. & I just received this from Freefly... (thanks for response!!)
    Make sure you're connecting through the Movi App, and that your system Location setting is set to High Accuracy or Battery Saver. If that doesn't work reach out to us through the site: https://freeflysystems.com/contact . Cheers!
     

Share This Page