Canon rebel XSi FPV

Discussion in 'Cameras' started by Paul conto, Feb 13, 2013.

  1. Paul conto

    Paul conto Member

    Joined:
    Feb 13, 2013
    Messages:
    244
    Likes Received:
    19
    I'm going to be flying my rebel XSi and was wondering if anyone knows how to turn off the timeout of the live view mode. I haven't hooked it up to my transmitter yet but I remember someone shooting with their 5D they had to turn on live view to get the video to go through there transmitter. I figured I had to do the same thing but after 30sec the live view turns off unless I take a picture. Anyone have any luck turning off the timer.
     
  2. Brad Meier

    Brad Meier Active Member
    Staff Member

    Joined:
    Aug 14, 2012
    Messages:
    749
    Likes Received:
    66
    In both the 5D and 7D its in the menu system. Not sure on the XSi...

    Just searched Google-> the XSi manual-> pg 109 talks about "auto power off". That may solve the issue..
     
  3. Michael McVay

    Michael McVay Active Member

    Joined:
    Dec 31, 2012
    Messages:
    416
    Likes Received:
    91
    Paul, here are a couple photos from the menu of a Canon T2i. I would bet the XSi has the same menu choices. I used to fly this camera from a helium balloon for aerial photos and never had a problem with it turning off. In addition to the Auto power off, take a look at the LCD auto off. I am not sure if that would interupt the signal being sent to your downlink or not, but I have the LCD auto off disabled.

    Good luck with it!

    photo 1.JPG photo 2.JPG
     
  4. Paul conto

    Paul conto Member

    Joined:
    Feb 13, 2013
    Messages:
    244
    Likes Received:
    19
    Awsome guys thank you, I'll be getting my gimbal Friday and hope to have it on my bird, a next level 800 hex, by Sunday. Going to be interesting once I get it on, I'll throw some pics up of the hack job :)
     
  5. Paul conto

    Paul conto Member

    Joined:
    Feb 13, 2013
    Messages:
    244
    Likes Received:
    19
    thank you guys, it works perfectly now. Going to do some testing later today with hooking it up to a transmitter and doing the FPV with it. Unfortinently UPS is deciding to take the long way of shipping my gimbal, even though it shipped wensday and i selected 2nd day air, and instead of getting it today i may have to wait until monday before i can mount it and start flying.
     
  6. Paul conto

    Paul conto Member

    Joined:
    Feb 13, 2013
    Messages:
    244
    Likes Received:
    19
    Have the gimbal mounted just need to program the radians, but i decided to get my camera gear going and run into an issue. I bought the shutter cable from quadrocopter, http://www.quadrocopter.com/Shuttercable_p_309.html, got it all wired together and plugged into my receiver, not running MK flight system, but as soon as i power the receiver it takes a pic and wont "reset" to allow my to snap pics with a switch. Im using a JR12X and wondering if i need to program something in the radio or since I'm going a strait into the receiver i need something other then this cable. If i cant plug it strait into the receiver could i plug it into the radio output and program it that way?
     
  7. Gary Haynes

    Gary Haynes Administrator
    Staff Member

    Joined:
    Jul 6, 2012
    Messages:
    5,211
    Likes Received:
    460
    Check with QC but I think this one only runs off of the MK stack. Description says it runs on one the "transistor circuits".
     
  8. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,371
    Likes Received:
    1,162
    Gary's right. This is designed to be driven off a transistor switch (e.g. the Extension PCB) not an RC channel (it doesn't understand PWM).

    Andy.
     
  9. Paul conto

    Paul conto Member

    Joined:
    Feb 13, 2013
    Messages:
    244
    Likes Received:
    19
    Ok ill see what i can dig up for a different remote shutter then I have a new problem though. I have my radians setup, tuned, and spektrum satellite installed but for some reason channel 8 is not responding. Im going to be piloting and operating the camera so my channels are limited. the only work around i have right now is to not have a mode switch and use channel 7 to slew the tilt. I would really like to have a mode switch to turn the gimbal off and on, mostly as a precation incase of crash to save the system. any ideas?
     
  10. Brad Meier

    Brad Meier Active Member
    Staff Member

    Joined:
    Aug 14, 2012
    Messages:
    749
    Likes Received:
    66
    I would use Aux3 which is the rotary knob top right. Was that your original thinking and the channel your not able to use?
     
  11. Paul conto

    Paul conto Member

    Joined:
    Feb 13, 2013
    Messages:
    244
    Likes Received:
    19
    Acually was going to use the slider on the right as AUX 3. But yes the radian is not reading channel 8 no matter what I switch it to knob, slider, or switch.
     
  12. Brad Meier

    Brad Meier Active Member
    Staff Member

    Joined:
    Aug 14, 2012
    Messages:
    749
    Likes Received:
    66
    Paul, Im assuming this is a DX-8 we are talking about correct?

    Open the radian software and navigate to window->input channel monitor. Move the slider or knob and see what channel that movement corresponds to. Connect the tilt Radian and Read the current settings. Under Slew, assign that channel that you want to use.

    You may have done that much already... If thats not working are you getting a response on the channel monitor when moving the slider or knob?
     
  13. Paul conto

    Paul conto Member

    Joined:
    Feb 13, 2013
    Messages:
    244
    Likes Received:
    19
    JR12X radio. Looking at the monitor all channels up to 7 get a response. Channel 8 has nothing no matter what I assign to it.
     
  14. Brad Meier

    Brad Meier Active Member
    Staff Member

    Joined:
    Aug 14, 2012
    Messages:
    749
    Likes Received:
    66
    Oh ok.. in post #9 above ... "I have my radians setup, tuned, and spektrum satellite installed but for some reason channel 8 is not responding."

    So your using a JR12X with a Spektrum satellite?
     
  15. Paul conto

    Paul conto Member

    Joined:
    Feb 13, 2013
    Messages:
    244
    Likes Received:
    19
  16. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,371
    Likes Received:
    1,162
    Paul:
    Can you check the JR12X's Monitor screen (see page A-58 of the manual). You should be able to see whether RC Channel #8 is doing anything at the transmitter (it appears to be designated as RFLP). If it's not working there, then evidently there is something odd about the transmitter setup.

    Hope this helps
    Andy
     
  17. Paul conto

    Paul conto Member

    Joined:
    Feb 13, 2013
    Messages:
    244
    Likes Received:
    19
    The monitor shows that channel 8 has movement. ANOTHER issue i have now run into as well. I finally got some legs installed and when i went to try a test flight my NAZA was just blinking failsafe. Plugged it into the computer and it wasn't getting anything from my receiver, perplexed i rebound it it worked fine. But then i lost slew control on the gimbal! I rebound that and lost my Main receiver, even though the lights were on. I then tried binding both at the same time, since I'm using just the satellite for the gimbal i ran a second receiver with the satellite installed then plugged it back into the radian. They both received the bind, powered everything down, plugged the satellite into the radian and then only had gimbal control the main receiver again wasn't sending anything to the NAZA.
    I though you could bind 2 receivers to the same transmitter, looked online and there are several posts of people doing it. So what am i dong wrong?
     

Share This Page