Binding Mimic v2.0.3 to Movi M15

Discussion in 'MIMIC' started by Luis Corchon, Apr 26, 2022.

  1. Luis Corchon

    Luis Corchon New Member

    Joined:
    Apr 15, 2022
    Messages:
    2
    Likes Received:
    0
    I am having issue binding my new Mimic to a Movi M15 with latest firmware.

    I defined the the MOVI CONTROLLER option on the app and tried to link my Spektrum receiver to it using various channels. No go.

    Do I need the RP-SMA or can I bind directly with the hardware that I have?

    I've also read that only Mimic Beta is compatible with the M series. Is it possible to downgrade the Mimic firmware to accomplish this on new hardware?

    Any help is appreciated!
     

    Attached Files:

    #1 Luis Corchon, Apr 26, 2022
    Last edited: Apr 26, 2022
  2. Graham Futerfas

    Graham Futerfas Well-Known Member

    Joined:
    Oct 19, 2015
    Messages:
    1,256
    Likes Received:
    243
    That new Mimic is incompatible with the older M15. It's meant to work with Movi Pro. On the older Movi's (M5/10/15), you need the Mimic Beta, which is a completely different piece of hardware.
     
  3. Luis Corchon

    Luis Corchon New Member

    Joined:
    Apr 15, 2022
    Messages:
    2
    Likes Received:
    0
    Thanks for the fast feedback. I had a feeling this would be the case. I'm new to the Freefly product line but I'm going to go ahead and order a Movi Pro.
     

Share This Page