Battery Messed Up?

Discussion in 'MōVI M5' started by Harrison Freni, Nov 11, 2014.

  1. Harrison Freni

    Harrison Freni New Member

    Joined:
    Oct 10, 2014
    Messages:
    1
    Likes Received:
    0
    Hey, I have been doing a shoot recently, and I forgot to turn off the movi: This was in my office with no direct sunlight & room was at room temp. When I came back from lunch, the movi had died, and when I went to go charge the battery, I just got a blinking green light. How would i fix this ? :(
     
  2. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,369
    Likes Received:
    1,162
    I'm afraid that is the one thing that Lithium Polymers really don't like -- over discharging them. If you have one of the higher end chargers you can sometimes coax the LiPo back to life (do a Google search for: recovering LiPo batteries), but the odds are slim.

    Andy
     
  3. Steve Maller

    Steve Maller UAV Grief Counselor

    Joined:
    Oct 30, 2012
    Messages:
    3,979
    Likes Received:
    807
    I thought the MōVI had a low voltage cutoff? Did I imagine that? Or was that a feature request that I submitted?
    I've killed a MōVI battery because I unplugged the MōVI but forgot that the battery was also running my vTX, which ran the battery flat.
     
  4. Andy Johnson-Laird

    Andy Johnson-Laird Administrator
    Staff Member

    Joined:
    Jul 31, 2012
    Messages:
    10,369
    Likes Received:
    1,162
    I think the MōVI effectively shuts down operation (that is, the motors) at a voltage around 14v (14.4 sticks in my mind), but I think the controller is still operating and over-discharges the LiPo.

    I've got a couple of LiPo savers from QC that I want to try to see if they will save LiPos, but I've not had a chance to try them.

    Andy.
     

Share This Page