Anyone in here using Redrock Micro focus torque motor on MoviPro?

Discussion in 'MōVI Pro' started by Adam Brennan, Mar 15, 2021.

  1. Adam Brennan

    Adam Brennan Member

    Joined:
    Dec 29, 2013
    Messages:
    234
    Likes Received:
    14
    I was on a recent shoot and had the Redrock Micro focus torque motor on some cine lenses. The motor works fine when it's not engaged to a cine lens. Put it on a cine lens it won't turn it. Caused a lot of issues and delays on the set not to mention embarrassing when the Monstro is on a MoviPro. I am starting to think Redrock Micro is more of a DSLR solution than anything true cinema. Are their Fiz motors junk? What else is out there that works well with the MoviPro? I am using the Redrock micro Navigator to focus but will that work with a different Fiz motor on the MoviPro? Just wondering if i should scrap the Redrock micro fiz system due to lack of quality or reliability. Thoughts or experience?
     
  2. Dave Lerrick

    Dave Lerrick New Member

    Joined:
    Nov 6, 2016
    Messages:
    1
    Likes Received:
    1
    Hi Adam,
    In case you haven't already reached out to their support team I can only say from my experience they are very responsive and helpful. The situation you were in defenetly sucks and does not suppose to happen, I would ask myself the same questions.

    I have not used these focus torque motors so can't comment on them but I own Redrock Micro Atlas Motors that work well with cine lenses and are purpose built for the Navigator. When using the Navigator plugged in to the Movi Pro you can use it with other motors like I have successfully used it with the Chrosziel CDM-100M motors.

    Regards,
    Dave
     
    Alejandro Selman likes this.
  3. Alejandro Selman

    Alejandro Selman New Member

    Joined:
    Mar 27, 2017
    Messages:
    7
    Likes Received:
    2
    Hi Adam,

    Based on the issue you described, I suspect your Torque Motor requires servicing. If you haven’t already, please contact our Support team at support@redrockmicro.com with your info and serial number. They’re best suited to troubleshoot and assist you directly.

    As Dave mentioned, it’s definitely a bummer when these things happen, and the Navigator works with other lens control motors that are compatible with the MoVI Pro.
     
  4. Blue Sky Aerials LLC

    Joined:
    Jul 28, 2016
    Messages:
    3
    Likes Received:
    1
    I own 3 torque motors and they have been pretty solid. I have had issues with one motors that vibrates but other than that they calibrate perfectly. If the lens you use has a stiff ring it might be too tight for the motor to drive. I always make sure that the lenses the camera dept gives me are nice and smooth with no high spots. If they are too tight the torque motor will stop during calibration, the system will think its hit its end of its travel.
     
    Alejandro Selman likes this.

Share This Page